Fordmods Logo

V8 Pinging under load 

 

Page 2 of 2 [ 28 posts ] Go to page Previous  1, 2

 
 Post subject: Re: V8 Pinging under load
Posted: Thu Jul 07, 2011 9:47 pm 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

LTD_DF wrote:
Thanks for that Hans.

I went there and finished up here: http://sbftech.com/index.php/topic,7114.0.html

Which gave me all i need to know in order to adjust my engines timing.

I'll have a crack at it this weekend and so if that puts and end to my troubles.

Thank you to all that contributed.

easier than typing and explaining it.you noted the different timing on our v8efi?

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Thu Jul 07, 2011 11:10 pm 
Parts Gopher
Offline

Age: 44

Posts: 71

Joined: 13th Mar 2011

Gallery: 8 images

Ride: Ford

Location: Gladstone
QLD, Australia

No

The title fo the link is "EFI" and i've not picked up on any special reference to our V8 EFI for Ford Fairlaines/Ltd's.

Please explain....
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Fri Jul 08, 2011 1:04 am 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

LTD_DF wrote:
No

The title fo the link is "EFI" and i've not picked up on any special reference to our V8 EFI for Ford Fairlaines/Ltd's.

Please explain....

i meant the us clip,similar,we run 30btdc at base idle-+\- 2 deg,depends on your motor set up,when hot,turn off and short the connector out.see a auto electrican and get 1 made up,the pins are small.re start motor-it will rev up,now you have 2 min. to set timming,you may have to do it a few times.

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Fri Jul 08, 2011 2:56 am 
Getting Side Ways
Offline

Age: 29

Posts: 546

Joined: 5th Jun 2010

Ride: BA XT, NCII V8

Location: Adelaide
SA, Australia

does it ping when u just rev it in N
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Fri Jul 08, 2011 10:11 am 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

wtbdlltd wrote:
does it ping when u just rev it in N

it wont,under load at 4500-5000 rpm

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Fri Jul 08, 2011 12:04 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Timing is usually the main reason...

BUT check fuel delivery as in filter, fuel reg etc
Then double check exhaust leaks, 02 sensor should be replaced
if over 100,000 KLrs ..

Colder plugs can help, along with slightly cooler thermostat..
Any oil inducted into inlet manifold can cause detonation so check
PCV on back of inlet manifold..

I fitted an alloy tube 70 mm which made it easier for any oil to run back
into engine...Or fit an oil separator?? They cannot be vented to atmo in EPA engine..
At that RPM any blocked exhaust exhaust can bring on these issues..
Other than above try some water / meth injection..
Google water water / meth ?? There are cheap kits out there..

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Fri Jul 08, 2011 7:00 pm 
Getting Side Ways
Offline

Posts: 699

Joined: 1st Jan 2006

Ride: Lots, all Fords

Location: Hamilton
New Zealand

It sounds like an air measurement fault to me. Under-measured air = insufficient delivered fuel in open loop = lean detonation. Clean the 2 MAF sensor elements and also verify MAF sensor is actually working with KOER test.

 

_________________

XA Faimont 351C, AU2 XR8 Manual 5.0, DA LTD 5.0, Mk1 Capri 5.0, 1995 Mustang 5.0, EF2 XR8 Manual, EF2 Fairmont Ghia 5.0, AU3 XR8 Auto, AU2 XR8 Auto, AU2 XR8 Manual Ute, TE Cortina 5.0 Manual, DU LTD 5.0 soon to be manual

Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Tue Jul 12, 2011 9:53 am 
Fordmods Newbie
Offline

Posts: 14

Joined: 12th Apr 2011

Ride: LTD NL 97

Location: perth
WA, Australia

yeha same thing was happening to me and it ended up being the air flow sensor just pull it out and have a look it should be clean. if not clean with CRC but DO NOT TOUCH wires.
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Thu Jul 21, 2011 10:15 am 
Oompa Loompa
Offline

Age: 32

Posts: 41

Joined: 9th Mar 2011

Ride: Ford EB Fairmont

Location: Melbourne
VIC, Australia

Funny coz im having this same issue, I bought the car from this old fella about 4 months ago and it would ping under load at the same mentioned RPM range. Got the mechanic to check the timing and he mentioned that it was on the mark. Keep in mind the cars done 329,xxxkms on it but mostly highway

Then i vagly remembered that the old man mentioned he used to use propane in the car, so that got me thinking....would it have been a possibility that the tank had propane in it and then was tuned which means it will def ping due to normal LPG and unleaded(even premium) having lower octane rating.

So i ran the car until it was out of gas filled up propane, gave it lil belting and guess what no pinging.
On Unleaded forget its worse, start putting ur foot down a little even and she starts pinging, starting to s**t me.
Ive changed fuel filter, upper cylinder clean & cleaned AFM's damn thing still wont stop.

Im still new to this so if anyone can show me where the MAF sensors are id be more than happy to clean em and see if it helps
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Mon Jul 25, 2011 11:21 pm 
Fordmods Newbie
Offline

Posts: 14

Joined: 12th Apr 2011

Ride: LTD NL 97

Location: perth
WA, Australia

liquid_ice wrote:
Funny coz im having this same issue, I bought the car from this old fella about 4 months ago and it would ping under load at the same mentioned RPM range. Got the mechanic to check the timing and he mentioned that it was on the mark. Keep in mind the cars done 329,xxxkms on it but mostly highway

Then i vagly remembered that the old man mentioned he used to use propane in the car, so that got me thinking....would it have been a possibility that the tank had propane in it and then was tuned which means it will def ping due to normal LPG and unleaded(even premium) having lower octane rating.

So i ran the car until it was out of gas filled up propane, gave it lil belting and guess what no pinging.
On Unleaded forget its worse, start putting ur foot down a little even and she starts pinging, starting to s**t me.
Ive changed fuel filter, upper cylinder clean & cleaned AFM's damn thing still wont stop.

Im still new to this so if anyone can show me where the MAF sensors are id be more than happy to clean em and see if it helps


Image
red section is the MAF, unplug wire and 2 screws then clean the two inside wire very carefully. you can buy CRC MAF cleaner put its real expensive or just use CRC general lubricate (what i did) one just don't touch with fingers. mine works great now
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Tue Jul 26, 2011 9:25 am 
Oompa Loompa
Offline

Age: 32

Posts: 41

Joined: 9th Mar 2011

Ride: Ford EB Fairmont

Location: Melbourne
VIC, Australia

Awesome, thanks for that. But isnt there 2 MAF sensors????

Nice clean engine bay there.....very snazzyy :)
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Tue Jul 26, 2011 7:37 pm 
Fordmods Newbie
Offline

Posts: 14

Joined: 12th Apr 2011

Ride: LTD NL 97

Location: perth
WA, Australia

liquid_ice wrote:
Awesome, thanks for that. But isnt there 2 MAF sensors????

Nice clean engine bay there.....very snazzyy :)


nah it has two wire but in the one section.
By the Way that engine bay ISN"T mine just used it cause it has MAF sensor on the side so its easier to see, Its a picture out of another thread.
wish it was mine though.
Top
 Profile  
 
 
 Post subject: Re: V8 Pinging under load
Posted: Sat Jul 30, 2011 10:56 am 
Parts Gopher
Offline

Age: 44

Posts: 71

Joined: 13th Mar 2011

Gallery: 8 images

Ride: Ford

Location: Gladstone
QLD, Australia

I've been down with a savage dose of the flu, but yesterday i got the energy to cean my MAF and hey presto the pinging is no longer.

Thanks to you all for helping me fix my problem.

Sincerely,

John
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 28 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:26 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names