Fordmods Logo

What could make my car cut out like this? 

 

Page 2 of 2 [ 29 posts ] Go to page Previous  1, 2

 
Posted: Sat Oct 13, 2007 11:32 am 
Stock as a Rock
Offline
User avatar

Posts: 161

Joined: 13th Jun 2005

Gallery: 4 images

Location: Rockhampton
QLD, Australia

Scaffy - I'm not an expert by any means but personally I wouldn't blame the alternator, especially if there was enough juice in the battery to crank the engine straight after it died... sounds more and more like fuel pump to me - my EF had much the same behaviour, filled up at Caltex one day and their pump ran completely dry (great stuff) and the very next week I had stop start trouble as the tank emptied (presumably sucking a ton of gunk). The filter was the first indication of this - heaps of rusty looking crap so I replaced it and the pump and all was good - I kept the old one as a spare but just manually running it off a battery it would run and then seize and then run again....
Top
 Profile  
 
 
Posted: Mon Oct 15, 2007 10:57 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

The reason I blame the altenator is because when idling for only a short time, the volts drop into the red and it dies. If I keep the revs at around 950 - 1000, it will stay up at around 13v and won't cut out. That was only the second time though. The first time I know it wasn't the alternator.

Now, I've noticed that when cruising at about 120, then take my foot off slightly, it chugs once or twice (every now and then) and carries on fine for the rest of the trip. It's done it a couple of times whilst cruising at lower speeds as well, but I've noticed it more on the freeway than anywhere else.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Mon Oct 15, 2007 11:18 pm 
Stock as a Rock
Offline
User avatar

Posts: 161

Joined: 13th Jun 2005

Gallery: 4 images

Location: Rockhampton
QLD, Australia

What is the earth like to the engine block ? It's almost as if the earth lead is loose and losing contact at idle ....
Top
 Profile  
 
 
Posted: Mon Oct 15, 2007 11:23 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Wouldn't have a clue... I'll check it if you can tell me where it is. Why would it be loose when it's idling at about 800rpm but not at 1000rpm?

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Mon Oct 22, 2007 10:40 pm 
Stock as a Rock
Offline
User avatar

Posts: 161

Joined: 13th Jun 2005

Gallery: 4 images

Location: Rockhampton
QLD, Australia

Sorry for the late reply Scaffy - the earth thing is only a shot in the dark... it's probably likely to cut out at 800 rpm cause there's generally more vibration at lower revs... just make sure you battery contacts are good and tight and follow the black lead and see if it's all good...
Top
 Profile  
 
 
Posted: Mon Oct 22, 2007 11:48 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Yeah mate, the earth is good. Will be replacing the whole ignition setup in a week so I'll just have to wait til after that to see if it's fixed. It happened again the other night, leaving the gfs parents place. I found by turning off anything electronic that it started a bit quicker.

I'm hoping that by replacing the ignition, alternator and battery, on top of the other work, will fix my problem. I think the twEECer will be getting replaced by the switch chip as well as it's not 100% compatible with my computer.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Tue Oct 23, 2007 12:29 pm 
Getting Side Ways
Offline

Age: 108

Posts: 927

Joined: 27th Sep 2007

Location: Adelaide
SA, Australia

hey scaffy,i would look at either the fuel pump or the ignition module for the dizzy if they havent already been checked.

 

_________________

165 Killer Wasps all packaged in a green kmart car, almost an explorer in a way...

Top
 Profile  
 
 
Posted: Tue Oct 23, 2007 8:15 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

fuel pump is something else I've considered. I have a brand new Warlbro 255l/hr sitting next to me as I type! It'll be going in next week also :)

I haven't checked ignition module cos I don't even know what it is! haha. It'll be getting replaced next week as well.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Tue Oct 23, 2007 8:36 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

I had the same problem/similar symptoms - loose battery terminals and TFI module stuffed!!!

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Tue Jun 10, 2008 3:00 am 
Fordmods Newbie
Offline

Age: 38

Posts: 6

Joined: 9th Feb 2008

Power: 138 rwkw

Location: Melbourne
VIC, Australia

Scaffy wrote:
fuel pump is something else I've considered. I have a brand new Warlbro 255l/hr sitting next to me as I type! It'll be going in next week also :)

I haven't checked ignition module cos I don't even know what it is! haha. It'll be getting replaced next week as well.


So what was the fix? Reason I ask is that I have the same issue
Top
 Profile  
 
 
Posted: Tue Jun 10, 2008 6:59 am 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

Definitely sounds like TFI. good way to check, if it cuts out, pour cold water over the TFI, if she starts again then definitely the TFI
My MSD Billet did this, would cause it to cut out when she got warm, cool her down with water and she would start.
Hope that helps
Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
Posted: Tue Jun 10, 2008 8:44 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Only a week after that, it went into the workshop for a couple of months and the top end got replaced and pretty much the whole igniition system too. Also the fuel pump. So, I'm guessing something in all that fixed it.

Sorry I can't tell you for sure mate.

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
Posted: Tue Jun 10, 2008 9:39 pm 
Parts Gopher
Offline

Posts: 71

Joined: 21st Jul 2007

Ride: xr8

Location: sydney
NSW, Australia

my 2 cents fuel pump!
Top
 Profile  
 
 
Posted: Wed Jun 11, 2008 1:52 am 
Getting Side Ways
Offline

Age: 37

Posts: 1273

Joined: 30th Sep 2007

Ride: g6e 2009

Location: hiding in the bushes
WA, Australia

im gonna throw in a dirty fuel pump answer
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 29 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Wed Dec 13, 2017 3:06 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names