Fordmods Logo

*^Windsor *^ No Power above 3,000rpm on Petrol??? 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: *^Windsor *^ No Power above 3,000rpm on Petrol???
Posted: Fri Aug 15, 2008 4:03 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 613

Joined: 5th Aug 2007

Location: Ararat
VIC, Australia

EF Ghia-Windsor Duel Fuel

And guys before you tell me the HO Equipped Windsor is only good for 4,500 rpm, I know this- I am talking like no movement at all above 3,000! Like a blockage??

Engine runs fine on Propane (Never run blend)

When running on petrol engine runs great whilst keeping revs below 3,000 rpm. Take it above that and theres nothing AT ALL.

Now I only know about the Windsor motor from the 122 pages of forums on here, and workshop manuals (Although its EB-ED V8 Book, same tho without Clutch fan) so my "novice" conclusion would be for me to check:

IGNITION TIMING (although idles fine on both fuels)
MAF
INJECTORS
Fuel pump (and lines)

Can rule out a intake blockage or filter issue's due to car still loving the Propane and running fine.

Has also done the same thing with all diff types of ULP inc PULP, And eth blend...

ideas??? :idea:

Also just how much of the computer does the LPG system use? Its an Impco copy (LG) with sprintgas mixer.

 

_________________

EF Ghia 5L V8
BAMk2 XR8 Velocity/Cobra 19's

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 4:10 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Mild f@rt here but, does the EF run a dizzy like the EL?
If yes then the timing could be set nicely for LPG but not for petrol.

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 6:39 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2282

Joined: 14th Jan 2005

Gallery: 8 images

Ride: ED Fairmont Ghia & EF XR8

Location: Melbourne
VIC, Australia

Vic wrote:
Mild f@rt here but, does the EF run a dizzy like the EL?
If yes then the timing could be set nicely for LPG but not for petrol.


5l runs dizzy up until au

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 7:35 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Okay good thanks.
I must have been confusing them with EF I6's.

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
Posted: Fri Aug 15, 2008 8:30 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

You mentioned filters not being a problem, but have you replaced the fuel filter? Low fuel flow will cut the fun factor big time.

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
Posted: Sat Aug 16, 2008 12:50 am 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 613

Joined: 5th Aug 2007

Location: Ararat
VIC, Australia

V8 Ghia Mike wrote:
You mentioned filters not being a problem, but have you replaced the fuel filter? Low fuel flow will cut the fun factor big time.

Mike


Will be checking tomorrow, but I was referring to Ait filter- thanks Mick

Yeah I think the timing could be a little bit of an issue-BUT usually if its just the timing motor will still rev past 3,000rpm, but ping and generally be a b**ch.

 

_________________

EF Ghia 5L V8
BAMk2 XR8 Velocity/Cobra 19's

Top
 Profile  
 
 
Posted: Sat Aug 16, 2008 12:53 am 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Sounds like either fuel pump,fuel filter or fuel pump relay or all three to me.
Top
 Profile  
 
 
Posted: Sat Aug 16, 2008 11:42 am 
Parts Gopher
Offline

Age: 43

Posts: 97

Joined: 4th Aug 2008

Ride: XC GXL

Location: perth
WA, Australia

If its ever backfired on gas theres a chance the hotwire in the airflow meter is burnt. Ive seen them covered in varnish and had sucess cleaning them(carby clean but dont drown it.) If no dice try a known good part off :wink: a mates car etc. It wont use the MAF on gas.

 

_________________

XC GXL 5.8: 14.1 @ 99MPH. Thank you to Jimbos alchoholic uncle for the short motor. It goes alright now mate.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 9:29 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names