Fordmods Logo

Speedo 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Speedo
Posted: Mon Mar 13, 2006 3:16 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1181

Joined: 13th Dec 2005

Gallery: 3 images

Ride: 98 Patrol

Location: Maryborough
QLD, Australia

Hey guys my speedo in my XF fairmont ghia is playing up. On the digital read out it used to show it goes 60km/h or wat eva i was goin and then it drops to showing 0km/h even though im still driving. To fix it i just put the lights on then off and it comes back and at night the oposite i.e of then on. But now its just gone completely. Could i have knocked something wen working on it?
Thanks

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Mar 17, 2006 9:05 pm 
Stock as a Rock
Offline
User avatar

Posts: 122

Joined: 25th Apr 2005

Gallery: 9 images

Ride: EL Fairmont Ghia

Location: Gold Coast
QLD, Australia

Sounds knacked, Have you ever had it open before? Maybee it's as simple as a loose conection inside the display?

 

_________________

Knower of ALL......Master of NOTHING !!!

Top
 Profile  
 
 
Posted: Fri Mar 17, 2006 9:33 pm 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

probably a dead cluster

 

_________________

Banned

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 8:55 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names