Fordmods Logo

The FD LTD Lives... 

 

Page 3 of 6 [ 84 posts ] Go to page Previous  1, 2, 3, 4, 5, 6  Next

 
Posted: Sun Aug 05, 2007 12:31 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

pulled the terminals off the battery thismorning, to have a look for dirt and grease and to check the connections....

im suprised we had ANY form of circuit happening in this car - the amount of grease and dirt that had worked its way down into the terminals was quite scary really.

cleaned all that up to get nice clean contacts, and tried to crank it....

still not firing.


i remember when i got the car, it would never want to ever start on fuel - the only way you could get it started was to start it on LPG, and then flick back to fuel.
this is somehting that we have never solved either, as when we wanted to move it, just started it on lpg - which is now not on the car.
but in saying that - last weekend, we got it to fire and run (badly as it was running) but it would still start on fuel. there was no residual lpg at all in the system as all the hoses and whatever had been cracked open to get them off.

the only other thing i can think of, would be the timing is out about 180... but we havnt touched it that much from last weekend for it to be out that much.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Sun Aug 05, 2007 2:31 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

http://smg.photobucket.com/albums/v146/ ... 007004.flv

heres a vid of the ltd cranking over, thats all we can get it to do right now.

adjusted timing bacck and forth to try to find a sweet spot, but there just doesnt seem to be one

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Sun Aug 05, 2007 3:17 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

http://smg.photobucket.com/albums/v146/ ... 007005.flv
(4mb video - possibly not dailup friendly...)

current situ - she starts, and runs...

definatly seems to have a missfire / not firing at all on one cycl - the exhaust is dumping a hell of a lot of black smoke too.

idle on the TB has been turned up, to the point where the screw is flush with the surface.

she will run by herself for a minute or so, but then slows, f@rt and stalls - as seen in the above video.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Sun Aug 05, 2007 6:32 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

im still sus about that AFM there easialy damaged sadly

this is gunna sound stupid but you did use ALL the FD computer, loom, and sensors yea?

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Sun Aug 05, 2007 7:02 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

84_Fairlane wrote:
im still sus about that AFM there easialy damaged sadly

this is gunna sound stupid but you did use ALL the FD computer, loom, and sensors yea?


yeah we did use all the FD loom - just took the zl head and used that.
the only things in the FD now from the zl are:
- the head
- The fuel rail
- fuel injectors
- coolant temp sender (matched onto the fd loom - two wires where 'joined'
- lower inlet manifold
- S "curve" hose - as FD one had also been haccked up to accomodate LPG.

everything else on the car, is hopefully how it left the factory 23 years ago...

its currently out of fuel atm, so have to wait a couple of days to get the money to be able to drop 20 or so litres into the tank.

worked out a possible reason for it running so very rich - we haddnt hooked up the coolant temp sender properly into the block, but thats sorted now.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Mon Aug 13, 2007 2:48 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

just had a thought on this, maybe the TPS has packed it in?

im unsure of how to test this tho.

is the ZL TPS the same as a ZK/FD one? if so can they easily swap over and run?

still havnt gotten around to getting some fuel into the tank, might do that today while im out and about.

Cheers

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Mon Aug 13, 2007 7:21 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

TPS wont matter at idol (shouldent have an output), and again its different to a ZL/XF one!

but it is the same as a VL one

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 7:38 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

im finally going to do something on the LTD - going to go and fill the Jerrycan a couple of times to get a reasonable amount of fuel in the tank to be able to continue starting the thing :S

hopefully....
itl run....
and without issue...

but im not holding my breath anymore - im getting quite past the problem of not being able to have it start and run properly.

if i could get it started and sit idling, i can then start playing with timing to get it spot on and the like.

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 8:43 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

dont loose heart! you'll remember why u love it when you get to take her for a spin!

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 10:13 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

unfort to be able to take it for a drive, requires that i get it roadworthied - and thats financial commitment i havnt allowed for, esp as iv quit work for a while.
at least il have a fair bit of time to play around with it to get it running.
Im looking foreward to the moment when it is registered and i take it for a drive, it will be a very worthwhile im sure and rewarding. i just have to get to that point..

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 10:48 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

id be so tempted to slot in a later model engine.....and EFi... Apparently they fit.

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 11:17 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

shes currently got an efi in her - but its the bosch efi.

if she wasnt numbers matching, i would have gone to town on her with a nice late model engine and trans etc.
but as its numbers matching, im gunna be sticking with whats in it - for originalities sake. :) :)

next one i get, il prolly go to town on that :)

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 11:21 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Fair enough man! Thats a nice model thats for sure

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Thu Aug 16, 2007 11:31 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

i personally think that this model ltd is the best from the fc/d/e including the fairlanes as well
its just got a lot of presence - it demands attention, and not coz its currently a garden ornament.
like, i think you see more of the older fairlanes and ltds getting around, but not that many from the zj/k/l fc/d/e ranges.

im most definatly looking foreward to cruising in it - i just got to get it to the stage where i can.

once its got fuel, should be right to play around again and get it running right :)

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
 
Posted: Fri Aug 17, 2007 8:45 pm 
Tyre Shredder
Offline

Age: 32

Posts: 384

Joined: 26th Jun 2005

Ride: 1984 FD LTD

Location: Mackay
QLD, Australia

progress has been made!

it now has fuel in the tank - she was once more BONE DRY.
The guage in the dash is out a fair bit, its constantly reading half a tank of fuel.
sounds like the fuel pump is starting to let go as well - but i have a spare newie here that i can put in it inc the sender as well.
by changing the tank sender, my dash guage should read correctly?
i knew she was out of fuel without having to look at the gauge, but for road use, il need a working guage im sure - dont really wanna be stuck on the side of the road.

fired it over a couple of times - she WANTS to fire
can feel it wanting to kick over and run, which is goodly :)

we found a small problem - the spark plug in number 6 wasnt in, took us a minute to work out why she was 'puffing' out the side of the head when cranking (working in the dark, so couldnt really see anything)

will be playing around more with it tomorrow - in the light of day :)

progress looks like its taking place finally

 

_________________

Member Of "Team LWB"
FD: My Current Project

http://img.photobucket.com/albums/v146/ ... age029.jpg

ZL: A Work In Progress - that went to the tip!

http://img.photobucket.com/albums/v146/ ... maller.jpg

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 6  [ 84 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:04 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names