Fordmods Logo

XF S-Pac Fuel Gauge. 


Page 2 of 2 [ 17 posts ] Go to page Previous  1, 2

 Post subject: Try fixing the old cluster
Posted: Mon May 01, 2006 6:42 pm 
Fordmods Newbie

Age: 44

Posts: 5

Joined: 1st May 2006

Ride: Falcon

Location: Canberra
WA, Australia

My XF also blacks out etc. and has been through phases of very erroneous fuel readouts that seem to self-correct after a bit. I think the reason they black out is because of the button used to toggle between oil/voltage and fuel/temp. This presses direct on the solder track and cracks it. This is only a theory that I haven't checked as I have been too lazy to remove the unit. Since you have the unit out already I would suggest taking a look at this area of the circuitry and if it is cracked - solder it back up and put the original back. I think the guage is dependent on a resistor to calibrate the voltage from the sender, so if you have a unit from a sedan and the wagon has a bigger tank, you may have problems.
Posted: Sun May 07, 2006 2:43 am 
Getting Side Ways
User avatar

Age: 37

Posts: 1938

Joined: 10th Nov 2004

Gallery: 31 images


Location: THE DRUITT
NSW, Australia

sorry to hijack the thred but my 5.0L seems to be more fuel efficent & are there any X seriesFM members in Sydney??
If so come tothe dyno day or a cruise sometime as it would be good to see the X series out in force.




Display posts from previous:
Sort by  
 Page 2 of 2  [ 17 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 5 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 12:58 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names