Fordmods Logo

xf ute problems 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: xf ute problems
Posted: Mon Jun 11, 2012 11:09 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 16

Joined: 15th Dec 2010

Ride: EA Fairmont Ghia

Location: Batemans Bay
NSW, Australia

hey guys i have an xf ute with 3.3L engine, was running on lpg for a long time, but now i want to switch it back to petrol, the timing was changed to run better on lpg, anyway i have been trying to run it on petrol, i have removed the gas line that went into the air cleaner and the thing that was on top of carby where it went into, then it was running rough on petrol and would misfire or backfire thru the carby but it would seem fine when driving around at higher speeds no problem, i know its not the spark plugs because they are basicly brand new, so i looked at the dizzy which has the numbers for the leads imprinted on it and i saw that the wrong leads were going to the wrong spots, but when i pulled the lead out from the top of the dizzy i saw that the number 3 lead was all rusted inside and had corroded/rusted the point on the dizzy which was actually for number 5, i then tried to clean the inside of the lead and the point the best i could and then put the leads onto the dizzy following the numbers then i tried to start it and it wouldnt fire, like it wasnt getting spark, went back and double checked all the leads and points on dizzy, tried to start again and still didnt fire but there was one or two popping noises, so i took the dizzy cap off, all the points inside were covered in black buildup i guess carbon, and the same on the end of the rotor, also where the coil spring in the top comes down and touchs the rotor were all black,so i wiped it all off, tried to start it and it did start but it ran really rough for about 10 seconds then died again... also it looked like the rotor would be barely even touching the points.... so what should i do? new dizzy cap, leads and rotor? also is there a difference between the EA/EB dizzy cap/ rotor? because i cant seem to find one for a xf. any help would be muchly appreciated
Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:13 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

I'm not 100% sure, but I thought there were 3 dizzy's for the XF.....normal electronic, the EST one, and the one for EFI.
I thought the EST one shared the same cap as the EA to EL.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:18 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 16

Joined: 15th Dec 2010

Ride: EA Fairmont Ghia

Location: Batemans Bay
NSW, Australia

i have no idea, i just know it doesnt work, my ute is automatic btw
Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:21 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 16

Joined: 15th Dec 2010

Ride: EA Fairmont Ghia

Location: Batemans Bay
NSW, Australia

i just found this, " If its backfiring through the carby it's an almost dead certanty that you have the ignition timing 180degrees out.

Try swapping leads 1-6, 2-5 & 3-4 on the distributor cap & I bet it fires right up." so i will do that tomorrow and let you know
Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:24 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

what you need to do is ignore the numbers on the dizzy cap and get a repair manual for the xf,

replace all the dirtied up bits on the dizzy that can be replaced, or chase up an electronic one. and go through the firing order correctly and set it to tdc#1, then if you get it to fire(which it should if everything is working fine) get a timing light and adjust the dizzy to the correct setting for petrol, chances are it was advanced for gas and it pinged on petrol.

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:29 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 16

Joined: 15th Dec 2010

Ride: EA Fairmont Ghia

Location: Batemans Bay
NSW, Australia

hey bry40l thanx for the info, remember when i posted about that filthy eb fairmont, well i sold that and it got used in a high speed pursuit and clocked going 192 kph lol i must have done something right to that one
Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:38 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 16

Joined: 15th Dec 2010

Ride: EA Fairmont Ghia

Location: Batemans Bay
NSW, Australia

what i really want to know tho is if the dizzycap/ rotor from and EA / EB with CPI is interechanged able with the one i have, i have seen them on ebay and they look exactly the same
Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:50 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

spanglebilly wrote:
hey bry40l thanx for the info, remember when i posted about that filthy eb fairmont, well i sold that and it got used in a high speed pursuit and clocked going 192 kph lol i must have done something right to that one

It went that fast? Id hate to crash the poor thing at 50km let alone 190+

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: xf ute problems
Posted: Mon Jun 11, 2012 11:55 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 16

Joined: 15th Dec 2010

Ride: EA Fairmont Ghia

Location: Batemans Bay
NSW, Australia

i never got the whole story, but what i got was some guy without a license was driving it, got clocked going 192 out ran 3 highway patrol and a paddy wagon, they had to stop pursuit coz it was going so fast and then they found it later abandoned and no keys, and thats all i heard about
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 2:37 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names