Fordmods Logo

Slight prob with bf6t 


Page 1 of 1 [ 2 posts ] 

 Post subject: Slight prob with bf6t
Posted: Sun Apr 11, 2010 8:38 pm 
Stock as a Rock

Age: 36

Posts: 181

Joined: 4th Aug 2006

Gallery: 2 images

Ride: 97 EL futura & BF XR6 Turbo

Location: sydney
NSW, Australia

Hey all I'd like to know if anyone had a problem like I did it's a bf sII when it's under pressure it seems to turn the stereo off on it's own then switch back on or if I give it a bit and stability control get activated the lights on the dash come on and the speedo stops working when I turned the car off then start it up again it's fine I was told that a cell in the battery is gone but somehow I don't think it would cause this much hassle oh also when I try to start it it seems like it's dead but then it will fire up I have lost a fair bit of power also but doesn't the battery on then just to start then the alternator takes over or is it different from the e series



there is only 2 rules in driving go hard or go home

 Post subject: Re: Slight prob with bf6t
Posted: Thu Apr 29, 2010 11:25 am 
Stock as a Rock
User avatar

Age: 48

Posts: 102

Joined: 30th Nov 2004

Gallery: 2 images

Ride: V8 LTD DC

Location: Cranbourne
VIC, Australia

I have issue with speedo (as you described) on one of BA XT at work. Ford said its problem with computer, they know about it but they cannot provide any solution at this stage. This car failed to start from time to time as well.



BA XT Wagon 2004 -daily driver
LTD DCII V8 1993
NC-1 1991
NA-II Sportsman 1990- budget project going very slow: full respray is in progress, XR6 engine, rebuild auto, lowered, 3.45 LSD, extractors, LTD leather electric seats, thermofans, NF door trims, NF door handles, complete NCII wiring.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 6:27 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names