Fordmods Logo

1994 Ef fairmont abs locks up help 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: 1994 Ef fairmont abs locks up help
Posted: Wed May 22, 2013 2:18 am 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

My 1994 ef fairmont wagon has abs and the front locks up in the wet
Any way I can fix it ??
Top
 Profile  
 
 
 Post subject: Re: 1994 Ef fairmont abs locks up help
Posted: Mon May 27, 2013 11:58 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

Help ??
Top
 Profile  
 
 
 Post subject: Re: 1994 Ef fairmont abs locks up help
Posted: Tue May 28, 2013 3:15 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Clearly, your ABS isn't working properly. Any warning lights on the dash? Your front brake rotors would have been replaced (several times probably). Were they replaced with rotors with the correct ABS tone rings? I believe the EL had different slot spacing, and non-ABS rotors have no tone ring at all (obviously). Otherwise, your ABS pump could have failed; but I would expect to see a constant warning light if that was the case.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: 1994 Ef fairmont abs locks up help
Posted: Tue May 28, 2013 3:19 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

No lights on the dash all I have dose is changed the pads and not it locks up
Top
 Profile  
 
 
 Post subject: Re: 1994 Ef fairmont abs locks up help
Posted: Tue May 28, 2013 5:46 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Are you saying that it works now after replacing the pads? Brake fluid on the pads can cause lock-up.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:42 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names