Fordmods Logo

4 speed auto in EF XR6- Strange Shifting. Please help!! 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Tue Aug 11, 2009 2:12 pm 
Fordmods Newbie
Offline

Posts: 9

Joined: 30th Oct 2008

Location: Newcastle
NSW, Australia

I have a EF XR6 with a auto tranny that has been giving me the willys.
Generally the car is good but once the car heats up to operating temp i get intermittent shifting issues ( not all the time, only sometimes).

I'll be driving down the freeway at 100k's in Drive and then all of a sudden the gbx will jump into 2nd gear and sent the revs rocketing. sometimes it will change back to 4th after a few seconds but otertimes it will stay in 2nd gear. If i change the gear stick between D and 3rd it has no effect. Then when i change back to 2nd it will act as though it is in drive.

Other times i can be driving along and the car will neutralise. and i can shift between 2-Drive with no effect. only when i go to 1st it picks up first gear and away i go.

The oil and filter is good. I replaced but this didn't fix the problem...
Anyone had any simialr issues?
Top
 Profile  
 
 
 Post subject: Re: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Tue Aug 11, 2009 8:50 pm 
Smokin em up
Offline

Posts: 266

Joined: 1st Sep 2007

Location: melbourne
VIC, Australia

Sounds Like the S2 solenoid playing up

Gassa

 

_________________

When the clutch drops the bull s**t stops!!!!!

Top
 Profile  
 
 
 Post subject: Re: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Tue Aug 11, 2009 9:12 pm 
Parts Gopher
Offline

Age: 49

Posts: 54

Joined: 27th May 2009

Ride: Ford TE50 Charged

Location: Melbourne
VIC, Australia

As above i had 4 of them replaced in mine. Take it to someone who knows what there doing. May not need a full rebuild if it changes correctly at other times.

Regards
Top
 Profile  
 
 
 Post subject: Re: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Wed Aug 12, 2009 9:48 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

Basics first... Check the plug on the neutral switch on the passenger side of the box. Make sure its in properly and the contacts are clean.

Next try to get hold of a known working neutral switch and swap it over and see if that improves things. They are simply a resistance wheel and when they die they can do all sorts of weird things, even along the lines of what your explaining.

If that no fix, then its something in the box.
Top
 Profile  
 
 
 Post subject: Re: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Wed Aug 12, 2009 1:14 pm 
Fordmods Newbie
Offline

Posts: 9

Joined: 30th Oct 2008

Location: Newcastle
NSW, Australia

I'll give it a go.
Is there a sensor for the gear selector position that could be playing up?
Top
 Profile  
 
 
 Post subject: Re: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Wed Aug 12, 2009 1:22 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

roy91tt wrote:
I'll give it a go.
Is there a sensor for the gear selector position that could be playing up?


The gear position sensor is in the neutral switch. The small white module on the passenger side of the transmission.

When these stuff up, they have been known to cause the issues you are describing.
Top
 Profile  
 
 
 Post subject: Re: 4 speed auto in EF XR6- Strange Shifting. Please help!!
Posted: Fri Aug 28, 2009 8:09 am 
Fordmods Newbie
Offline

Posts: 9

Joined: 30th Oct 2008

Location: Newcastle
NSW, Australia

Yep it was the neutral switch
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 10:05 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names