Fordmods Logo

4 speed auto power/economy switch 


Page 4 of 4 [ 48 posts ] Go to page Previous  1, 2, 3, 4

Posted: Tue Mar 01, 2005 5:42 pm 
Fordmods Newbie
User avatar

Posts: 10

Joined: 22nd Feb 2005

Gallery: 4 images

Location: Taranaki
New Zealand

Not long (2 months) after I bought mah EL, I stepped out to pass a car and I lost drive, the car redlined. I throttled off and then applied power again and still no drive, then THUMP in went gear and off we went.... untill i realised that I only had 1st, 2nd and third - it wouldnt go into 4th / overdrive.
Called up the mech warranty people (thank god for mech inurance) and off my falcon went to get fixed.
Picked it up and the guy said "dunno who fixed it last time but they didnt know what they were doing" They spent near $4000 bucks fixing the box, had to replace parts "we dont normally have to replace".
3 months later and the thing was screaming whenever power was applied and it had to go back for more work.

At its last service the guy told me after the flush that there was very fine metal powders in everything... *sigh*

Now two years later and reverse has packed a s**t.... works when i put in in reverse and let idle do the work - ok on the flat - but try a little throttle and I got no reverse for a bit then shudder shudder shudder and we take off backwards like a rocket.
Mechanic has to take it out of car and send it away for inspection. Repairs could cost anywhere from $500 to $2000 bucks!!!

Bloody autos.

Never had ANY problems with my EB2 and should have kept her!!!

Drew :shock:



Bog stock 98 EL Futura 4.1 with a pod filter.

Posted: Tue Mar 01, 2005 8:10 pm 
Fordmods Newbie

Posts: 17

Joined: 1st Mar 2005

Location: Canberra
ACT, Australia

Just to chuck my 2c in....

I recently bought an EF and decided to test econ v normal - I'd prefer to drive in normal but if econ was gonna save me considerable money I'd live with it. Over 2 weeks (1 econ, 1 normal) normal came out anout 0.5L/100ks better than econ. I was also pushing it a fair bit harder during the 'normal' week, with plenty of hard acceleration.

A couple of weekends ago I was towing a trailer (as long as the EF and a couple of feet wider) and I found econ cut the fuel consumption considerably, according to the trip meter.

As others have mentioned, in econ I find I need to give it more juice to maintain speed, expecially when going up hill at 60ish.

My next test will be driving in normal as conservatively as I did in my econ week. I expect I'll see considerable difference.

Posted: Sun Mar 06, 2005 1:38 am 
Parts Gopher
User avatar

Age: 39

Posts: 56

Joined: 6th Jan 2005

Gallery: 5 images

Ride: XH XR6 UTE

Location: Perth
WA, Australia

Once again the ugly Economy Vs Power mode thread has started again,
I didnt really think this would pop up in the Suspension, Brake and Driveline Workshop forum, try having a look in the ECU and Fuel System Forum, mate theres a bazillion theories and answers for this subject.



See Ya on the road Scag...see ya on the road.

Display posts from previous:
Sort by  
 Page 4 of 4  [ 48 posts ]  Go to page Previous  1, 2, 3, 4

Who is online

Users browsing this forum: No registered users and 8 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 7:39 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names