Fordmods Logo

AU V8 Auto 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: AU V8 Auto
Posted: Fri Apr 27, 2007 10:46 pm 
Parts Gopher
Offline

Age: 70

Posts: 86

Joined: 30th Nov 2004

Ride: AU II Fairmont Wagon V8 Tickford

Location: Melbourne
VIC, Australia

Mine has done 225000 and been exellant up to date. Always flushed at 50k, fluid is cherry red ATM. The lock up is dropping in and out and revs increase by 300 - 400. Shifts all seem soft! Whats the best trannie place in Melbourne. I think Bayford do all the rebuilds for Ford, but I dont think a rebuild is due just yet. Fluid drive in Richmond has been recommened to me - whats the BEST place

I have looked at this site on line ( http://www.automatictransmission.com.au/ ) sounds good too

any ideas

Ray

 

_________________

AU II V8 Fairmont Wagon ORGANZA
Tickford Factory Suspension
HM Headers, 1/2 inch spacer
BA/F FTG Wagon Red F6 , 6 speed auto and it goes

Top
 Profile  
 
 
Posted: Mon Apr 30, 2007 3:52 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 512

Joined: 6th Feb 2006

Gallery: 3 images

Ride: BA Falcon Classic

Location: Perth
WA, Australia

sounds like theres f**k all oil in ur torque converter..

 

_________________

When you do things right, people won't be sure you've done anything at all.

Top
 Profile  
 
 
Posted: Mon Apr 30, 2007 5:05 am 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

I had a similar problem with lockup dropping in and out, also trans wouldn't hold 3rd when selected with the shifter (this was all intermittent).
Occasionally it would also slam a 1st to 2nd shift.
I suspected inhibitor switch, swapped it out this weekend, and it fixed it.
I'm not sure how much they are brand new, but they are very easy to change (2 plugs, 2 8mm bolts, on the passenger side of box), so maybe worth a crack?

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
 
Posted: Tue May 01, 2007 11:33 pm 
Parts Gopher
Offline

Age: 70

Posts: 86

Joined: 30th Nov 2004

Ride: AU II Fairmont Wagon V8 Tickford

Location: Melbourne
VIC, Australia

Steady ED wrote:
I had a similar problem with lockup dropping in and out, also trans wouldn't hold 3rd when selected with the shifter (this was all intermittent).
Occasionally it would also slam a 1st to 2nd shift.
I suspected inhibitor switch, swapped it out this weekend, and it fixed it.
I'm not sure how much they are brand new, but they are very easy to change (2 plugs, 2 8mm bolts, on the passenger side of box), so maybe worth a crack?


YES !! Its not holding 3rd today, and the fluid is full - dribbles out of the fill hole, so its getting a new inhibitor switch - will let u no what goes

Thanks

 

_________________

AU II V8 Fairmont Wagon ORGANZA
Tickford Factory Suspension
HM Headers, 1/2 inch spacer
BA/F FTG Wagon Red F6 , 6 speed auto and it goes

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 2:46 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names