Fordmods Logo

BA 5.4 3v Fairmont Ghia Gearbox Limp Mode Issues 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: BA 5.4 3v Fairmont Ghia Gearbox Limp Mode Issues
Posted: Mon Mar 24, 2014 6:30 pm 
Parts Gopher
Offline

Age: 29

Posts: 69

Joined: 14th Nov 2009

Ride: EL Falcon / XG Panelvan

Hi guys, long story short, I have 02 BA 5.4L 3v Ghia with a 4spd BTR transmission, now car was

running like a dream, gearbox blew a oil pump gear, all was replaced by a tranny joint, now when

putting gearbox back in car everything was fine, go to put the battery in car, a little tired and

whatnot I put it in back to front, and fried the main fuse in engine bay and a host of smaller ones in

the car under the dash. Car drives fine, but when its cold - particulary when its cold, it goes into

limp mode at the slightest bit of acceleration, or when its loaded up ie towing a car - my question

is have I fried the ECU at all? I have had the auto tranny bloke scan tool it he says my solenoids on

gearbox are fine, and it has something to do with voltage drop causing the computer to go into limp

mode. Has this happened to anyone else?

Cheers
Top
 Profile  
 
 
 Post subject: Re: BA 5.4 3v Fairmont Ghia Gearbox Limp Mode Issues
Posted: Mon Mar 24, 2014 8:26 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Check the battery & alternator voltage.

B series and FG's are very sensitive to voltage drops.
Top
 Profile  
 
 
 Post subject: Re: BA 5.4 3v Fairmont Ghia Gearbox Limp Mode Issues
Posted: Mon Mar 24, 2014 8:41 pm 
Parts Gopher
Offline

Age: 29

Posts: 69

Joined: 14th Nov 2009

Ride: EL Falcon / XG Panelvan

yeah I'll do that SWC.

I ordered one of those bluetooth scantool things so I can get a reading, or can I just use a multimeter in the mean while? Battery is brand new.

Cheers
Top
 Profile  
 
 
 Post subject: Re: BA 5.4 3v Fairmont Ghia Gearbox Limp Mode Issues
Posted: Mon Mar 24, 2014 8:46 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

You can use a multimeter across the terminals to check battery voltage when the car is off. Should read around mid to upper 12v range. When car is running should be at around 13.8 to 14.5v.
Also check contacts are clean and tight.

Make sure your multimeter leads are set correctly to measure voltage and not current or you will short the battery.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: BA 5.4 3v Fairmont Ghia Gearbox Limp Mode Issues
Posted: Mon Mar 24, 2014 8:52 pm 
Parts Gopher
Offline

Age: 29

Posts: 69

Joined: 14th Nov 2009

Ride: EL Falcon / XG Panelvan

Alright will try that tommorow.

Cheers
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 9:12 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names