Fordmods Logo

BA sluggish reverse, delays to engage reverse 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: BA sluggish reverse, delays to engage reverse
Posted: Thu Nov 13, 2014 5:21 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

I've noticed my BA when put in reverse, it delays to engage sometimes and asking 2 other mates with BA fords also have this sluggish reverse
Any ideas guys? I want to fix before it gets any worse
So I pulled up at work and parked the car but don't like to be so close to other people due to damage occurring so I tried to reverse, took foot off brake pedal and it rolled forward so I applied brakes again for couple seconds and it engaged
What can cause this ? Thanks in advance guys

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Thu Nov 13, 2014 5:33 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

123esproc wrote:
I've noticed my BA when put in reverse, it delays to engage sometimes and asking 2 other mates with BA fords also have this sluggish reverse
Any ideas guys? I want to fix before it gets any worse
So I pulled up at work and parked the car but don't like to be so close to other people due to damage occurring so I tried to reverse, took foot off brake pedal and it rolled forward so I applied brakes again for couple seconds and it engaged
What can cause this ? Thanks in advance guys


When was the gearbox last serviced?
Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Thu Nov 13, 2014 6:21 pm 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 56

Joined: 5th Mar 2014

Ride: 1998 EL Fairmont Ghia

Location: Wairarapa
New Zealand

I'd recommend a gearbox service too, if you're not sure when it was done last.
Old trans fluid gets thick and has trouble passing through the filters and generally doing its job. I had all sorts of weird shift delays and random no-gearing-at-all problems until I got my 'box serviced.
After that its been 100% fine.

 

_________________

Cheapie EL Fairmont drag car build thread

Next: DIY shift kit, lowering springs and shocks, new rims, nitrous kit, nitrous purge, line locker

Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Thu Nov 13, 2014 7:01 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

The auto on my BA is the same and its always serviced every 20-30k. Its been like that since we bought it with 40,000 kays. My transmission guy says for BAs its pretty normal.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Fri Nov 14, 2014 6:14 am 
Parts Gopher
Offline
User avatar

Age: 41

Posts: 56

Joined: 5th Mar 2014

Ride: 1998 EL Fairmont Ghia

Location: Wairarapa
New Zealand

93EB wrote:
My transmission guy says for BAs its pretty normal.

Well, that sucks.
Wonder if the delay is due to the CPU running some kind of safety check to make sure you're not still rolling forward?

 

_________________

Cheapie EL Fairmont drag car build thread

Next: DIY shift kit, lowering springs and shocks, new rims, nitrous kit, nitrous purge, line locker

Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Fri Nov 14, 2014 8:37 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

its probably more to do with a lazy reverse servo or low line pressure in reverse..
Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Fri Nov 14, 2014 12:55 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

TROYMAN wrote:
its probably more to do with a lazy reverse servo or low line pressure in reverse..


Im sure he mentioned the 2 in a sentence but the main thing that sticks is that the auto was fine.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: BA sluggish reverse, delays to engage reverse
Posted: Fri Nov 14, 2014 4:17 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

OK so a service is in order cheers guys

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 4:59 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names