Fordmods Logo

Brake Issues 


Page 1 of 1 [ 2 posts ] 

 Post subject: Brake Issues
Posted: Sun Mar 20, 2005 10:26 pm 
Oompa Loompa

Posts: 34

Joined: 12th Nov 2004

Gallery: 5 images

Ride: Falcon EBII Gli 5 Speed

Location: Newcastle
NSW, Australia

Hi, I recently got a new clutch installed into my eb2 falcon and ever since i have got it back, the brake pedal feels stiffer and less responsive. Also recently sometimes the car wont start and the brake fail light flashes on as if the computer isnt letting the car start. This problem goes away after pumpin the brake a bit. I have checked the brake fluid and all seems fine there, what could be the go?

Posted: Mon Mar 21, 2005 8:17 am 
Getting Side Ways

Age: 34

Posts: 533

Joined: 12th Jan 2005

Location: Melbourne
VIC, Australia

Pump the brake till it's really firm without the engine running. Put your foot hard on teh brake without the engine running. Then, with your foot on teh brake, start the car.

The brake pedal should go down another inch or so just after the car starts. If nothing happens, you've got a torn diaphram in your brake booster.... either that or the vacuum connection to your booster is disconnected/leaking.
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 6:15 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names