Fordmods Logo

Brake Vacuum Problem 


Page 1 of 1 [ 2 posts ] 

 Post subject: Brake Vacuum Problem
Posted: Sat Jun 06, 2009 7:23 pm 
Fordmods Newbie

Age: 51

Posts: 3

Joined: 29th May 2009

Ride: Ford Cortina 1974

Location: sunshine Coast
QLD, Australia

Here's an intriguing problem.
In normal use, the brakes on my TD Cortina operate perfectly satisfactorily.
When the car is used in reverse and the brakes applied, more often then not the pedal sinks nearly to the floor and there is very little to no braking effect.
After rapidly pressing the pedal approximately five times there is pressure again.
This can be very disconcerting when reverse parking, etc....
It's a 1974 Cortina with a mileage of 55 000 km's.
The car is fitted with the original booster, but the previous owner has fitted an oversize disc & caliper upgrade. The original rear drums are there with good shoes fitted.

Has anyone else experienced this problem? And can anyone shed some light on an answer?
 Post subject: Re: Brake Vacuum Problem
Posted: Sat Jun 06, 2009 9:29 pm 
Getting Side Ways
User avatar

Age: 48

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Are the brake shoes adjusted properly????? are the shoes fitted correctly ( leading and trailling )?????



Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 1:02 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names