Fordmods Logo

EB Auto wont manual down shift. 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: EB Auto wont manual down shift.
Posted: Tue Jan 05, 2010 5:17 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Hi guys,
I have noticed on occasion my Auto wont manually downshift gears. It acts as if though its in drive still. If i turn the engine off and restart it everything works properly again and manual down shifts work.
Any suggestions..... :? Could it be the inhibitor switch?

Note: When this occurs auto upshifting and down shifting still works perfectly and smoothly.

Cheers
Shaun.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Tue Jan 05, 2010 9:00 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3448

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

93EB wrote:
Hi guys,
I have noticed on occasion my Auto wont manually downshift gears. It acts as if though its in drive still. If i turn the engine off and restart it everything works properly again and manual down shifts work.
Any suggestions..... :? Could it be the inhibitor switch?
Unlikely

Note: When this occurs auto upshifting and down shifting still works perfectly and smoothly.

Cheers
Shaun.


More than likely it would be an S1,S2,S3,S4 Solenoid in the box. EF 640070A1 is the Part number and they cost $74.00 each from Ford. They are fairly easy to change and you will just require a Torx bit, 10mm socket and ratchet, car ramps, TQ95 and, while your at it you could replace the filter and a NEW gasket. :)
Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sat Jan 09, 2010 5:02 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

I have fixed this in my EB Sedan by replacing the inhibitor switch. Also check the selector linkage bushes for wear.

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sat Jan 09, 2010 5:12 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Thaks Ben thats next on the cards. Ive re crimped and soldered the negative terminals going to the battery hoping a dodgey earth might be contributing but ill do the switch next if its still the same. I have not driven the car since ive done this yet. The inhibitor switch ive always been suss about but.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sat Jan 09, 2010 5:33 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3448

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

93EB wrote:
Thaks Ben thats next on the cards. Ive re crimped and soldered the negative terminals going to the battery hoping a dodgey earth might be contributing but ill do the switch next if its still the same. I have not driven the car since ive done this yet. The inhibitor switch ive always been suss about but.


I will bring the one I have at home for you Next week if you like?

Better still, come around and get it? I am not far from you, just PM me :D
Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sat Jan 09, 2010 8:58 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Thanks Papa. Yeah bring it please next week and i will let you know how it goes in the mean time. As i said to Ben today i have put new plugs on all the earth wires connecting to the battery and whilst i was at it i done the ISC as well and the idle has now improved but ive only driven the car around the block. The wires did look a bit crook being corroded and greenish. Its been a bit hot to do anymore. i will grab the switch earlier of you if it fails all together.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sat Jan 09, 2010 9:20 pm 
Getting Side Ways
Offline
User avatar

Posts: 633

Joined: 21st Nov 2008

Location: Melbourne
VIC, Australia

it has happened to me, replaced the inhibitor switch, problem solved
Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sun Jan 10, 2010 8:11 am 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Well ill be leaving the XR at home today and ill drive the EB :( . Ill let you all know how it goes. I hope if there is a problem it is the Inhibitor switch. Either way thats the next easiest thing to try so i will take everyones advice and do that next.

Thanks
Shaun.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: EB Auto wont manual down shift.
Posted: Sun Oct 05, 2014 12:26 pm 
Fordmods Newbie
Offline

Posts: 8

Joined: 29th Jul 2010

Ride: 93 LTD dc

Hi guys, a few years later ,did you get it fixed by changing switch ??? I have no engine braking or manual downshifts ,but thinking c4 faulty.

Took inhibitor switch off and checked with ohm meter all within range. reverse light and n/p start
all ok.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 8:42 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names