Fordmods Logo

EL auto issues 

 

Page 1 of 2 [ 22 posts ] Go to page 1, 2  Next

 
 Post subject: EL auto issues
Posted: Thu Oct 23, 2014 6:30 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

Hi all, I am having some issues with the auto in my EL XR6, for a little while now it's been changing up into D even if the shifter is set to 3, if I shift to D then back to 3 it still stays in D, also occassionally it drops out of gear (more common) or down a gear (rarely).
I did an oil change and now the change from 1 to 2 is quite solid when cold, the shift improves when warm.
I don't know if it's related but the cruise control is no longer functioning, possibly for a similar time to the auto has been playing up, don't know if it's related or not.

Any ideas on what to check/test or am I up for another tranny???

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Oct 23, 2014 7:31 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Change the inhibitor switch.
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Oct 23, 2014 7:38 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

Any ideas from where and for how much?

Could this cause it to drop out of gear?

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Oct 23, 2014 8:30 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

outlawxr6 wrote:
Any ideas from where and for how much?

Could this cause it to drop out of gear?


Yes it will cause it to drop out of gear.

http://www.ebay.com.au/itm/GENUINE-FORD ... 3cd1cfcdbf
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Sat Oct 25, 2014 2:47 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

Any tricks to the removal of this switch, I've undone the two retaining bolts and disconnected it but it won't budge, I've tried soaking the shaft in wd40 but no go yet....

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Sat Oct 25, 2014 6:18 pm 
Getting Side Ways
Offline

Posts: 973

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

Big screw driver!! :lol:
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Sat Oct 25, 2014 6:53 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

Yeah tried that, doesn't want to budge...

What I ended up doing was using an egg-beater drill I drilled a 3mm hole in the upper section of the switch housing and then sprayed liberal amounts of contact cleaner into the hole, worked the shifter and repeated the process.
I then inserted the tube from a can of wd40 into the hole and filled it with the pressurised goodness into the switch, worked the shifter and repeated the process again.
After cleaning the outside I sealed up the hole with some RTV.

I took the car for a spin, the gearbox now responds to the shifter position where it wouldn't before.
I will get to try it out tomorrow on my way to work to see if it still behaves properly or not, time will tell....

If it stays working properly I'll order a new switch...

Still no cruise control though, the cruise indicator lights up on the dash but no functionality, save that for another day....

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 3:35 pm 
Stock as a Rock
Offline

Age: 26

Posts: 100

Joined: 22nd Apr 2012

Ride: Ford EL

Location: melbourne
VIC, Australia

i have an problem with my EL auto as when i put it to D it clunks from 1st to 2n and sometimes in 2nd it doesnt ingage and when around 50kph its in 4th and the car is vibrating like an manual is too high of a gear, so idk whats happening, I want to swap the transmission out
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 5:39 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

CrACk InjECtIoN wrote:
i have an problem with my EL auto as when i put it to D it clunks from 1st to 2n and sometimes in 2nd it doesnt ingage and when around 50kph its in 4th and the car is vibrating like an manual is too high of a gear, so idk whats happening, I want to swap the transmission out



Why not do what I did and drill a small hole in the inhibitor switch and give a good spray with wd-40 or similar and see if it changes anything????

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 6:31 pm 
Stock as a Rock
Offline

Age: 26

Posts: 100

Joined: 22nd Apr 2012

Ride: Ford EL

Location: melbourne
VIC, Australia

Ok, if that doesnt fix it, what next?
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 7:27 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

CrACk InjECtIoN wrote:
Ok, if that doesnt fix it, what next?



replace said switch
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 7:30 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

CrACk InjECtIoN wrote:
Ok, if that doesnt fix it, what next?


It may not "fix" which is why I said "changes anything" if it does change it's behavious at all then you know it's at fault.....

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 7:42 pm 
Fordmods Newbie
Offline

Posts: 8

Joined: 26th May 2007

Location: gold coast
QLD, Australia

Also bear in mind the S5 solenoid in the transmission,
When the S5 is faulty the change from 1st to 2nd can be a real thump,
I dont know if this is your problem but it may be,
An auto trans mechanic charges about $330 to replace solenoid, filter and fluid,
Mine was done at 210k's and now at 260 is still fine.
Lecherus
Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Thu Dec 04, 2014 7:48 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 582

Joined: 20th Nov 2004

Ride: xr6

Location: Brisbane
QLD, Australia

Mine was shifting real hard between 1st and 2nd, turned out to be too much fluid in the trans, I really hate the fact that there isn't a dipstick, what a dumb idea!!

 

_________________

Do it once, Do it right!!!!!!

Top
 Profile  
 
 
 Post subject: Re: EL auto issues
Posted: Fri Dec 05, 2014 12:08 am 
Stock as a Rock
Offline

Age: 26

Posts: 100

Joined: 22nd Apr 2012

Ride: Ford EL

Location: melbourne
VIC, Australia

Yeah, it thumps into 1st to 2nd and slips too, the car has down nearly 300xxx and it goes into 4th gears too early and it just shakes the car and i have to select 3rd and sometimes 2nd gear wont enage
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 22 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 4:10 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names