Fordmods Logo

EL Falcon "Whining" Noise 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EL Falcon "Whining" Noise
Posted: Mon Apr 07, 2014 5:58 pm 
Fordmods Newbie
Offline

Age: 22

Posts: 4

Joined: 6th Apr 2014

Location: Sydney
NSW, Australia

Hi everyone, i just recently joined this forum and i wanted to say that everyone seems to be very friendly to each other and helps each other out a lot.

Anyways my brother who recently got a '97 EL Falcon (also know as the Red Rocket) off my mum has been driving it around for about a month now. there seems to be a whining noise coming from the engine after we get over 5000rpm. does anybody know what this may be? has it happened to them? just some background info on the car is that when mum drove it she never got it over 3000rpm

Thanks in advance, Batesy
Top
 Profile  
 
 
 Post subject: Re: EL Falcon "Whining" Noise
Posted: Mon Apr 07, 2014 7:26 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

It could be a tensioner or idler pully on the way out. Hard to say without more info.
Top
 Profile  
 
 
 Post subject: Re: EL Falcon "Whining" Noise
Posted: Mon Apr 07, 2014 8:02 pm 
Fordmods Newbie
Offline

Age: 22

Posts: 4

Joined: 6th Apr 2014

Location: Sydney
NSW, Australia

Thanks for the reply SWC, what else would you need to know?
Top
 Profile  
 
 
 Post subject: Re: EL Falcon "Whining" Noise
Posted: Mon Apr 07, 2014 8:41 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Have you tried giving the motor a rev with the bonnet open, Don't rev it to 5000 rpm in neutral, you will do it damage.

Does the car perform alight otherwise?
Top
 Profile  
 
 
 Post subject: Re: EL Falcon "Whining" Noise
Posted: Tue Apr 08, 2014 8:41 am 
Fordmods Newbie
Offline

Age: 22

Posts: 4

Joined: 6th Apr 2014

Location: Sydney
NSW, Australia

Well not to long ago the radiator and heat or hoses broke, after that they had been fixed and the car was doing great. I read on here about a clunk in the diff area while changing to third from second. That's the only thing that has happened to the car, otherwise it's great.

Thanks again
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 2:11 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names