Fordmods Logo

Manual conversion problems 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Manual conversion problems
Posted: Sat Mar 29, 2014 12:47 pm 
Smokin em up
Offline

Age: 26

Posts: 276

Joined: 27th Jun 2007

Location: Melbourne
VIC, Australia

Hey guys, had someone pull my dash and chuck a T5 in my car, got a bit of a problem though.

Instead of doing the resistor mods I got the J3 flashed to a manual one, car starts fine but she runs real rough, miss firing, sounds like a top fuel dragster.

I changed the plugs as they were all fowled from being run with no resistors before the J3 was reflashed.

Is there anything more I have to look into regarding wiring etc for the conversion, besides the resistors (which I shouldnt need now)

Also got an airbag light flashing, any tips for the airbag light? I'm guessing connectors haven't been reseated properly or something? Brake switch isn't connected, I doubt that would be a problem?
Top
 Profile  
 
 
 Post subject: Re: Manual conversion problems
Posted: Sat Mar 29, 2014 8:27 pm 
Getting Side Ways
Offline
User avatar

Posts: 1427

Joined: 21st May 2005

Location: Melbourne
VIC, Australia

Regarding the rough running, I'd check your map sensor.
Maybe you bumped the tube off it during the conversion.

There's one small plug on the drivers side of the dash, easy one to miss when doing a dash out job.

 

_________________

EL Fairmont Ghia - Manual - Supercharged
- The Car
- The Headlights

Top
 Profile  
 
 
 Post subject: Re: Manual conversion problems
Posted: Mon Jun 30, 2014 9:51 pm 
Smokin em up
Offline

Age: 26

Posts: 276

Joined: 27th Jun 2007

Location: Melbourne
VIC, Australia

Got it all working with J3 without having to do resistor mods and got the car running, reverse switch wired up but now I have a vacuum leak from behind the dash, sounds like its coming from behind trip computer/stereo.

No heater controls working either.

Vacuum leak gets loud if you rev the car out.
Top
 Profile  
 
 
 Post subject: Re: Manual conversion problems
Posted: Mon Jun 30, 2014 11:03 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

well vacuum leak will give a rough running car!

and the vacuum is what controls the heater etc...

fix the leak = fixed many problems

 

_________________

RIP SCOTT

Top
 Profile  
 
 
 Post subject: Re: Manual conversion problems
Posted: Wed Jul 02, 2014 1:06 am 
Smokin em up
Offline

Age: 26

Posts: 276

Joined: 27th Jun 2007

Location: Melbourne
VIC, Australia

Disco Frank wrote:
well vacuum leak will give a rough running car!

and the vacuum is what controls the heater etc...

fix the leak = fixed many problems


Yep, was doing the thermofan rev up issue before the leak though.

Also anyone have a diagram of where the lines run around behind the dash for climate control? I think they're all a*** about.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:25 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names