Fordmods Logo

Power Steering Issue 


Page 1 of 1 [ 3 posts ] 

 Post subject: Power Steering Issue
Posted: Fri Sep 19, 2008 2:16 pm 
Stock as a Rock

Age: 31

Posts: 137

Joined: 30th Nov 2006

Gallery: 1 images

Ride: BF Fairlane Ghia

Location: Lithgow
NSW, Australia

Hi Guys,

I'm having a weird problem with my power steering on my EL Ghia.

Sometimes when I start the car, the steering wheel is totally locked and cannot move it without serious pressure. If I rev the car I can hear a very loud "whiring" noise, which does stop after about 5-6 minutes but I found if I turn the car off and start it again and it all appears to be fine.

I hope you guys can shed a bit of light on this topic.


Posted: Fri Sep 19, 2008 2:31 pm 
Getting Side Ways

Posts: 2425

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

SOunds like problems with the speed sensitive steering - perhaps a solenoid at the p/s pump that is frozen
Normally it adjusts the p/s pump pressure.

Posted: Sat Sep 20, 2008 5:55 pm 
Getting Side Ways

Age: 60

Posts: 437

Joined: 11th Nov 2004


Location: adelaide
SA, Australia

i had a simular issue with a pump i brought from the wreckers to use while i reconditioned mine

on start up - no power steering until you reved the motor and there was a bit of a whire then all was fine

i assume it was sticking or worn vanes in the pump - i will pull it apart one day to check
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 1:51 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names