Fordmods Logo

Serious brake imbalance, no fluid/pressure in FL calliper 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Serious brake imbalance, no fluid/pressure in FL calliper
Posted: Tue Nov 24, 2015 8:31 am 
Fordmods Newbie
Offline

Age: 19

Posts: 3

Joined: 21st Nov 2015

Ride: '96 EF Futura

Location: Auckland
New Zealand

Seriously need help on this one guys, I'm due for my WOF this week and only realised I had a brake imbalance when I needed to brake heavy yesterday and my 96 EF veered to the right and I had to correct it. I had a look at the front left calliper yesterday when I got home and decided to bleed it incase that was the problem, absolutely no fluid came out, with the engine running and the ABS fuse pulled there was nothing at all, no braking and no fluid, I took the bleed valve completely out and pressed the brakes hard multiple times and it was bone dry inside the calliper, not good, I undid the line going to the calliper, still nothing, so I undid the connection between the metal line and rubber line, still nothing, so I went to the ABS module and undid that line, absolutely bone dry, no fluid at all... Now I am in now ways useless I do all work on my car myself, however I have no f*cking clue how or why this has happened, and I assume it's pretty dangerous so I should fix it, but I don't even know where to start, what should I do? Could my ABS module be a goner? My car still stops on a dime and the abs works great, I honestly have no clue, I need to get around so please someone start replying soon!
Top
 Profile  
 
 
 Post subject: Re: Serious brake imbalance, no fluid/pressure in FL calliper
Posted: Tue Nov 24, 2015 1:20 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Do you have fluid before the ABS Unit?
Top
 Profile  
 
 
 Post subject: Re: Serious brake imbalance, no fluid/pressure in FL calliper
Posted: Tue Nov 24, 2015 9:34 pm 
Fordmods Newbie
Offline

Age: 19

Posts: 3

Joined: 21st Nov 2015

Ride: '96 EF Futura

Location: Auckland
New Zealand

SWC wrote:
Do you have fluid before the ABS Unit?


Yea I do all other 3 brakes work very well and have good pressure, out of 4 outlets on the abs module there is 3 that work, and one that is bone dry, and I can't figure out why
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: dp_stoner and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 5:45 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names