Fordmods Logo

zf6 problems please help 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: zf6 problems please help
Posted: Tue Jul 31, 2012 10:26 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 2

Joined: 28th Mar 2011

Ride: falcon xr8 ute bf

Location: gladstone
QLD, Australia

hi all , i have had this problem for a while now not sure if its a real problem its just annoying as all hell.

bf xr8 6 speed auto (can change gears up in tiptronic mode but not downshift)

anyone have any ideas it would be much appreciated

cheers...... :mrgreen:

 

_________________

IF IN DOUBT POWER OUT

Top
 Profile  
 
 
 Post subject: Re: zf6 problems please help
Posted: Thu Aug 02, 2012 6:20 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 15

Joined: 25th Jul 2012

Ride: Ford Falcon BF xr8

Location: Toowoomba
QLD, Australia

Hey man,
I own a bf xr8 sedan and have the ford workshop manual at home. I had a look through the diagnostic guideline for the zf 6 speed, and at a rough guess it sounds like an electrical fault, either with a sensor or wiring between the shifter and TCM (transmission control module). Hard to say though without the diagnosing software mechanical workshops have. With this you can connect to the TCM, and using fault codes it can a least point you in the right direction for the cause of the problem. Heres what the manual said:
"Possible Cause:
Wiring between shifter printed circuit board (PCB) and TCM defective or damaged. Incorrect software programmed TCM/PCM PCM parameters incorrect i.e. tyre size, axle ratio etc
Defective shifter mechanism Defective PCB Defective TCM Defective PCM"

"Transmission fault
If a major fault develops, the transmission may automatically operate in a ’limp home’ mode to enable the vehicle to be driven to an Authorised Ford Dealer for repair. During ’limp home’ mode, the transmission will still operate but with a limited operation dependant up on the fault detected and the transmission selector indicator on the instrument cluster will flash. Limp home mode may also be engaged if the battery charge falls below 9V.
With limp home, dependant up on the fault, the shift patterns can change and some of the gears may not be available."

Both of these paragraphs are copied straight out of the manual. Hope this helps man, best bet might be to take it to a workshop where they can a lease hook up the com adapter and access the fault codes...could be somthing simple like flash files, calibrations, limp mode etc.
Top
 Profile  
 
 
 Post subject: Re: zf6 problems please help
Posted: Fri Aug 03, 2012 12:22 am 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

if up is working but not down (or the other way), it indicates the trans is working fine, as is the wiring.

The problem is probably the in the shifter unit itself.

It uses a magnet on the shifter stalk, that when moved, triggers hall effect sensors that send the signal to the TCM in the box.

the magnet may not be aligned properly (you bashed it too hard one day?), or the hall effect sensor for 'down' is broken, you'll need a new shifter unit PCB.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
 Post subject: Re: zf6 problems please help
Posted: Fri Aug 03, 2012 12:29 am 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

Image
the hall effect sensors are the little black bits (6) on the bottom of the PCB (top here in this up side down shot).

You'll note there's a sensor for each of (top right) P, R, N, D, Dperf and Up (bottom left).

Down doesn't have one, as it is triggered by the fact none of the sensor will see the magnet when you move the shifter into the down position. So Down not working would indicate to me the magnet is not in alignment, so the Dperf sensor still sees it even when you push forward for down (and therefore thinks it's in the 'neutral' (not N) position between up and down.


edit: I occasionally have an issue with down on mine, it's not consistent though, and I have other options (steering mounted shifter buttons), so I haven't bothered to investigate.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
 Post subject: Re: zf6 problems please help
Posted: Fri Aug 03, 2012 1:06 am 
Fordmods Newbie
Offline

Age: 30

Posts: 2

Joined: 28th Mar 2011

Ride: falcon xr8 ute bf

Location: gladstone
QLD, Australia

thanks heaps for your help fellas ill have a look into it this weekend/pull it apart and possibly break more stuff lol..

 

_________________

IF IN DOUBT POWER OUT

Top
 Profile  
 
 
 Post subject: Re: zf6 problems please help
Posted: Tue Jun 17, 2014 4:35 pm 
Fordmods Newbie
Offline

Age: 63

Posts: 1

Joined: 17th Jun 2014

Ride: FG XR6T

Location: Upper Hutt
New Zealand

I got exactly the same problem with a 2009 XR6T 120,000km, so thanks for that detailed explanation. Can you post how you get on (and what it costs), as I don't really want to give it to Mr Ford and say "fix it". that's got me into $$$ troubles before. Cheers Stu
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 10:44 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names