Fordmods Logo

Sherro's EL Fairmont 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Sherro's EL Fairmont
Posted: Wed Nov 24, 2010 8:12 am 
Oompa Loompa
Offline

Age: 27

Posts: 23

Joined: 18th Nov 2010

Ride: 98 EL Fairmont Ghia

Location: Canberra
ACT, Australia

Okay, so I thought I would write up here chronicling my experiences with my EL as I do it up. I have little to no knowledge of cars and I am pretty keen to write here about how I go about learning things as I slowly do it up.

Updates might be slow as I just moved out on the weekend and bought the car on the 12th so I'm pretty low on funding.

MY CAR:
(I will put pics up later tomorrow once I take some)

The car has been running smooth since I got it as it was looked after fairly well, never missed a service and hasn't been driven much in the past 6-8 months. When I got my roadworthy inspection the mechanic replaced the tie end bar on the front right as apparently this was stuffed.

Second day of driving it the top radiator hose popped off driving it to work in the last 10 seconds and seemed to have drained all my coolant. Filled it up with water to get myself home. Drained the water and filled it with coolant. Looking into it more I found the hose connector on the end tank was cracked where the clamp goes.

Last weekend I drove to Sydney and back easily enough, no problems until I got to Lake George on the way back and the CD stacker stopped completely and showed the message "7 Err". Manually removed the cassette with a needle and couldn't find anything wrong It seems like the stacker is unable to eject the cassette. Gave up looking around and settled that I will buy a new head unit when I can as I wont use the stacker much anyway.

Yesterday I took the day off work sick and was driving to the doctor, 3/4 of the way there the hose must of popped off again as I could see the temperature rising slowly and the check cooling light showed up. Drove it 30 more seconds as a mechanic was nearby. He replaced the radiator for me.

Feeling pretty good that the main issue in my car was fixed I drove home, after having to stop at some traffic lights near my house I started driving off for a second the car didn't seem to want to move and the rpm hit about 7k when I heard a loud bang in the back left wheel. Next set of lights no amount of accelerator would give the car any revs, turned off and back on and all good. Approaching my house I noticed the car seemed to have trouble changing gears after downshifting and the oil pressure gauge was near the top. Stopped the car and had a look, absolutely s**t loads of oil underneath dripping from the pan under the engine block. Checked the dip stick to find it was full.

A mate of mine had a look and couldn't find anything except the power steering unit seemed a bit damp.

Hopefully the mechanic will tow it for me back as this problem wasn't there before.

more updates to come :)
Top
 Profile  
 
 
 Post subject: Re: Sherro's EL Fairmont
Posted: Wed Dec 08, 2010 9:00 am 
Oompa Loompa
Offline

Age: 27

Posts: 23

Joined: 18th Nov 2010

Ride: 98 EL Fairmont Ghia

Location: Canberra
ACT, Australia

Just took some pics after peeling off a gay 'Unit' sticker and the side pinstripes.

When I have more $$ I am hoping to get it lowered, new rims, clear indicator lights and HID kit. Then I will start on the engine.

Image

Image

Image
Top
 Profile  
 
 
 Post subject: Re: Sherro's EL Fairmont
Posted: Wed Dec 08, 2010 10:29 am 
Getting Side Ways
Offline

Posts: 2091

Joined: 3rd Apr 2008

Ride: EF Fairmont, XG Ute

Nice :D
Top
 Profile  
 
 
 Post subject: Re: Sherro's EL Fairmont
Posted: Wed Dec 08, 2010 10:38 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Nice and clean :). Looks like a good start :D.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Sherro's EL Fairmont
Posted: Wed Dec 08, 2010 11:00 am 
Oompa Loompa
Offline

Age: 27

Posts: 23

Joined: 18th Nov 2010

Ride: 98 EL Fairmont Ghia

Location: Canberra
ACT, Australia

Ill see if I can get around to changing the lense too.

Next Wednesday Im getting the head unit installed correctly, ive done a dodgy job in the mean time but I cant work out how the factory amp hooks into the deck + I cant mount it correctly.

Ill also get the car checked out, the oil pressure gague rises as I accelerate and basically redlines often.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:43 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names