Fordmods Logo

Temp gauge problem EL Falcon 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Temp gauge problem EL Falcon
Posted: Tue Aug 16, 2022 7:23 pm 
Tyre Shredder
Offline

Age: 58

Posts: 376

Joined: 27th Jan 2005

Gallery: 2 images

Ride: Falcon EL

Location: Bathurst
NSW, Australia

Hi troops, I'm in need of some assistance for my 4.0 EL Falcon.

Got my old EL falcon back about a month ago and have been giving her some loving which she hasn't had in some while. Replaced o2 sensor ISC thermostat temp sensor she even got a new antenna and heater tap and a few other things.

Now I don't know if I've knocked something while carrying out these repairs or its just happened out of the blue but now my temp gauge is playing up.

At first it seemed to intermittent the needle would just on its own go to hot then cold then normal then back to hot or cold or normal again. I put the cluster in dia mode and it would say 130 then 10 minutes later driving it would just plummet to 30 then up to 87or so then back to 130 and yet the car is not overheating. Temp needle now goes straight to hot when it is started in the morning cold and stays there for the entire trip to work about 30 minutes. Car drives fine but doesn't like to start again when the engine is warm but I do mange to get it started.

Strange enough even with the temp sensor plug not plugged into the new temp sensor the temp gauge still reads hot that is needle pegged all the way on 130.

Can anyone try to enlighten me on what the hell is going on???? I've a XR6 cluster in my el and all other gauges work fine...
Top
 Profile  
 
 
 Post subject: Re: Temp gauge problem EL Falcon
Posted: Thu Aug 18, 2022 7:03 am 
Tyre Shredder
Offline

Age: 58

Posts: 376

Joined: 27th Jan 2005

Gallery: 2 images

Ride: Falcon EL

Location: Bathurst
NSW, Australia

Just an update incase anyone else has similar problem, looks to be the new temp sensor. I took it out gave it a clean cleaned connection now seems to be working properly at the moment, I have another new sensor coming just in case.
Top
 Profile  
 
 
 Post subject: Re: Temp gauge problem EL Falcon
Posted: Tue Nov 29, 2022 8:08 am 
Fordmods Newbie
Offline

Age: 33

Posts: 5

Joined: 28th Nov 2021

Ride: Ford Territory 2020

Location: Melbourne
VIC, Australia

It's overheating. Check the thermostat and water pump, also radiator coolant levels. once you get it running at normal temp again take it to the shop and have them do a chemical test to see if the head gasket was damaged or the block was warped or cracked as this usually happens when your car overheats.

Affordable SEO Services Search Engine Optimization

Last edited by KellyP on Thu Feb 02, 2023 6:13 am, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: Temp gauge problem EL Falcon
Posted: Tue Nov 29, 2022 6:13 pm 
Tyre Shredder
Offline

Age: 58

Posts: 376

Joined: 27th Jan 2005

Gallery: 2 images

Ride: Falcon EL

Location: Bathurst
NSW, Australia

Turned out to be faulty temp sender that I replaced about 2 months or so ago, have replaced with another new one and now everything is fine.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Apr 18, 2024 10:05 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names