Fordmods Logo

Turbo Diesel - Bad rings or bad Turbo? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Turbo Diesel - Bad rings or bad Turbo?
Posted: Fri Sep 17, 2021 7:48 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 1472

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

sorry in advance everyone but i have no where else to turn i'm hoping there are a few Turbo Diesel experts here who can help me.

i have a 2006 Ssangyong Musso which has had a bit of work done to it, and yes i know this is a Ford site but like i said i have no where left to turn (Ssangyong forums dont allow new subs or topics)

anyway no smoke on start up, but a fair amount of grey smoke when driving normally and when you lift of the throttle it's Smoke city! (greyish/white) it has virtually zero acceleration i have to floor it to get anywhere and yea lots of grey smoke and the pipes to the intercooler seem pretty grimy

so far i have replaced the head gasket, glow plugs, radiator, water pump since the last owner said the head gasket was gone and thats why it had no acceleration and smoked like a chimney

from what i have researched bad rings & bad turbo have the same symptoms, one i can handle whiles if it's the the other (rings) i'll use this thing for target practice!

this TD has only done 240,000k's and these engines are known to last a very long time (not as long as our Fords but still 240k is still nothing for them)

once again very sorry but i am literally out of places to go

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
 Post subject: Re: Turbo Diesel - Bad rings or bad Turbo?
Posted: Sat Jun 25, 2022 8:34 pm 
Fordmods Newbie
Offline

Age: 40

Posts: 11

Joined: 4th Mar 2022

Location: Louisville
ACT, Australia

GTFORDMAN wrote:
sorry in advance everyone but i have no where else to turn i'm hoping there are a few Turbo Diesel experts here who can help me.

i have a 2006 Ssangyong Musso which has had a bit of work done to it, and yes i know this is a Ford site but like i said i have no where left to turn (Ssangyong forums dont allow new subs or topics)

anyway no smoke on start up, but a fair amount of grey smoke when driving normally and when you lift of the throttle it's Smoke city! (greyish/white) it has virtually zero acceleration i have to floor it to get anywhere and yea lots of grey smoke and the pipes to the intercooler seem pretty grimy

so far i have replaced the head gasket, glow plugs, radiator, water pump since the last owner said the head gasket was gone and thats why it had no acceleration and smoked like a chimney

from what i have researched bad rings & bad turbo have the same symptoms, one i can handle whiles if it's the the other (rings) i'll use this thing for target practice!

this TD has only done 240,000k's and these engines are known to last a very long time (not as long as our Fords but still 240k is still nothing for them)

Gilbert Towing
once again very sorry but i am literally out of places to go


Hey! did you fix this problem already?
Top
 Profile  
 
 
 Post subject: Re: Turbo Diesel - Bad rings or bad Turbo?
Posted: Sun Jul 03, 2022 10:20 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 1472

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

Quote:
Hey! did you fix this problem already?


yea it was a bad Turbo

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
 Post subject: Re: Turbo Diesel - Bad rings or bad Turbo?
Posted: Sat Jan 14, 2023 1:52 am 
Fordmods Newbie
Offline

Age: 30

Posts: 5

Joined: 19th Mar 2022

Location: Hampton
NSW, Australia

GTFORDMAN wrote:
Quote:
Hey! did you fix this problem already?

jewelry shop online near me
yea it was a bad Turbo

That was nice to hear.. Thanks for the update.
Top
 Profile  
 
 
 Post subject: Re: Turbo Diesel - Bad rings or bad Turbo?
Posted: Sat Mar 11, 2023 11:01 am 
Fordmods Newbie
Offline

Age: 40

Posts: 7

Joined: 23rd Nov 2021

Ride: Ford

Location: Manchester
NSW, Australia

GTFORDMAN wrote:
Quote:
Hey! did you fix this problem already?

link here

yea it was a bad Turbo



I expected to hear that. Good to know it's already fixed.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Apr 22, 2024 10:37 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names