Fordmods Logo

EF Fuel Pump and Sender 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: EF Fuel Pump and Sender
Posted: Sat Dec 04, 2010 3:29 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1434

Joined: 14th Jul 2008

Gallery: 1 images

Ride: Falcon EF Gli

Location: Melbourne
VIC, Australia

Hi,
Looking for a quick answer.
Is EA EB ED EF and EL fuel pump and sender the same? Are they all interchangeable from these models?
Thanks.
Izzy.

 

_________________

AsIzZy

My Build Thread:
post994940.html#p994940

For Sale Thread 1
forums/viewtopic.php?t=70845&highlight=

Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Sun Dec 05, 2010 12:56 am 
Getting Side Ways
Offline

Age: 30

Posts: 1434

Joined: 14th Jul 2008

Gallery: 1 images

Ride: Falcon EF Gli

Location: Melbourne
VIC, Australia

Bump..... Hopefully someone sees it.

 

_________________

AsIzZy

My Build Thread:
post994940.html#p994940

For Sale Thread 1
forums/viewtopic.php?t=70845&highlight=

Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Sun Dec 05, 2010 8:04 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

the whole assembly ,pump,carrier ect is pretty much the same. and will interchange.
if there is any real difference there may be a slight difference in the resistance in the sender..
worse case is the fuel gauge might be slightly off, but will still work...
Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Sun Dec 05, 2010 12:39 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1434

Joined: 14th Jul 2008

Gallery: 1 images

Ride: Falcon EF Gli

Location: Melbourne
VIC, Australia

Thanks for the detailed answers. And not just a yes or no.

The problem was that my car takes time to start nowadays. Like there's not enough fuel pressure or something like that. The other day it was a pretty warm day and I could hear the pump working like crazy well something was crazy in that region of the car. Any ideas?? I'm gonna replace these parts and see if it fixes it, I hope.
Thanks again.

 

_________________

AsIzZy

My Build Thread:
post994940.html#p994940

For Sale Thread 1
forums/viewtopic.php?t=70845&highlight=

Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Sun Dec 05, 2010 7:23 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1434

Joined: 14th Jul 2008

Gallery: 1 images

Ride: Falcon EF Gli

Location: Melbourne
VIC, Australia

I think I changed it 1.5 years ago. With hhmmm motocraft brand.

 

_________________

AsIzZy

My Build Thread:
post994940.html#p994940

For Sale Thread 1
forums/viewtopic.php?t=70845&highlight=

Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Mon Dec 06, 2010 9:52 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

TROYMAN wrote:
the whole assembly ,pump,carrier ect is pretty much the same. and will interchange.


The pumps and level senders are the same. Its been the same tank all the way through.

But the EL carrier frame is different. The hose connections are different on EL and may not work so well on EA to EF.
Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Mon Dec 06, 2010 11:09 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

arm79 wrote:
TROYMAN wrote:
the whole assembly ,pump,carrier ect is pretty much the same. and will interchange.


The pumps and level senders are the same. Its been the same tank all the way through.

But the EL carrier frame is different. The hose connections are different on EL and may not work so well on EA to EF.


yes, i know the late el is the same as au...
Top
 Profile  
 
 
 Post subject: Re: EF Fuel Pump and Sender
Posted: Mon Dec 06, 2010 11:21 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

Thought it was all EL's. All the EL wrecks and stuff I had all had the push on connectors.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 2:23 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names