Fordmods Logo

... supposed to be a High Series BEM. (Pics) 

 

Page 1 of 2 [ 22 posts ] Go to page 1, 2  Next

 
 Post subject: ... supposed to be a High Series BEM. (Pics)
Posted: Wed Jan 24, 2007 10:10 pm 
Parts Gopher
Offline
User avatar

Age: 38

Posts: 57

Joined: 29th Mar 2005

Ride: AU XR8... (Kia Grand Carnival)

Location: Oakhurst (Mt Druitt)
NSW, Australia

Hey Guys,

Just bought this from ford spares shop (module #1) last fortnight to replace a dodgy BEM for my EF Fairmont, but when I (finally) pulled out the origional (module #2) I'm p****d off to find they dont match. Any idea what I bought?


Module #1
Image
Image
Text is:

Made in Australia
9 330 065 164
P2019101 XX
96DA-14K144-BB GREEN
(Numbers on their side) 77099


Module #2
Image
Image
Text is:

Made in Australia
9 330 065 111
94DA 14K144 BA
56308

Now I got a dead car in the garage untill I can figure this out :(
Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 10:19 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

You got an EL High series one by mistake.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 10:31 pm 
Parts Gopher
Offline
User avatar

Age: 38

Posts: 57

Joined: 29th Mar 2005

Ride: AU XR8... (Kia Grand Carnival)

Location: Oakhurst (Mt Druitt)
NSW, Australia

twason wrote:
You got an EL High series one by mistake.
FFS, I told them it was for an EF. Ford specialists my a**.

Thanks for the info tawson, now I can sleep.
Top
 Profile  
 
 
Posted: Wed Jan 24, 2007 11:14 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

What's supposed to be wrong with the original EF one??

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 6:34 am 
Parts Gopher
Offline
User avatar

Age: 38

Posts: 57

Joined: 29th Mar 2005

Ride: AU XR8... (Kia Grand Carnival)

Location: Oakhurst (Mt Druitt)
NSW, Australia

snap0964 wrote:
What's supposed to be wrong with the original EF one??
its randomly cutting in and out, making the car stall at stupid times and hard to start most mornings.
Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 7:30 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 420

Joined: 30th May 2006

Gallery: 6 images

Ride: XR6

Location: Gosford
NSW, Australia

off topic but what did you pay?
have you tried cleaning up any dirty connections in the BEM worked for me give it a go.
Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 7:58 am 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

Jordan wrote:
snap0964 wrote:
What's supposed to be wrong with the original EF one??
its randomly cutting in and out, making the car stall at stupid times and hard to start most mornings.
I don't think the BEM is responsible here. If it was not turning over then maybe but it should not effect the car once running. What makes you suspect the BEM?

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 9:34 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

twason wrote:
Jordan wrote:
snap0964 wrote:
What's supposed to be wrong with the original EF one??
its randomly cutting in and out, making the car stall at stupid times and hard to start most mornings.
I don't think the BEM is responsible here. If it was not turning over then maybe but it should not effect the car once running. What makes you suspect the BEM?
Yeah, I agree with this. Also depends on what is mean't by 'hard to start' - does it motor over, etc.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 9:52 am 
Parts Gopher
Offline
User avatar

Age: 38

Posts: 57

Joined: 29th Mar 2005

Ride: AU XR8... (Kia Grand Carnival)

Location: Oakhurst (Mt Druitt)
NSW, Australia

snap0964 wrote:
twason wrote:
Jordan wrote:
snap0964 wrote:
What's supposed to be wrong with the original EF one??
its randomly cutting in and out, making the car stall at stupid times and hard to start most mornings.
I don't think the BEM is responsible here. If it was not turning over then maybe but it should not effect the car once running. What makes you suspect the BEM?
Yeah, I agree with this. Also depends on what is mean't by 'hard to start' - does it motor over, etc.
The reason I am replacing it is here:

http://www.fordmods.com/forums/viewtopic.php?t=37518

There is a fault somewhere which is making the BEM loose its earth connection, most likely compounded by a so-so battery giving less than ordinary voltage level. I have connected external battery jumper kits to rule out the battery so now its only the module left to test/replace.

Incidently this EL one cost me $110. If these guys wont swap it or refund then it will have to go on the For Sale section.
Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 10:04 am 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

Jordan wrote:
snap0964 wrote:
twason wrote:
Jordan wrote:
snap0964 wrote:
What's supposed to be wrong with the original EF one??
its randomly cutting in and out, making the car stall at stupid times and hard to start most mornings.
I don't think the BEM is responsible here. If it was not turning over then maybe but it should not effect the car once running. What makes you suspect the BEM?
Yeah, I agree with this. Also depends on what is mean't by 'hard to start' - does it motor over, etc.
The reason I am replacing it is here:

http://www.fordmods.com/forums/viewtopic.php?t=37518

There is a fault somewhere which is making the BEM loose its earth connection, most likely compounded by a so-so battery giving less than ordinary voltage level. I have connected external battery jumper kits to rule out the battery so now its only the module left to test/replace.

Incidently this EL one cost me $110. If these guys wont swap it or refund then it will have to go on the For Sale section.
It is possible to rewire the BEM connectors and use the EL BEM in an EF if you are stuck with it.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 10:14 am 
Parts Gopher
Offline
User avatar

Age: 38

Posts: 57

Joined: 29th Mar 2005

Ride: AU XR8... (Kia Grand Carnival)

Location: Oakhurst (Mt Druitt)
NSW, Australia

twason wrote:
Jordan wrote:
snap0964 wrote:
twason wrote:
Jordan wrote:
snap0964 wrote:
What's supposed to be wrong with the original EF one??
its randomly cutting in and out, making the car stall at stupid times and hard to start most mornings.
I don't think the BEM is responsible here. If it was not turning over then maybe but it should not effect the car once running. What makes you suspect the BEM?
Yeah, I agree with this. Also depends on what is mean't by 'hard to start' - does it motor over, etc.
The reason I am replacing it is here:

http://www.fordmods.com/forums/viewtopic.php?t=37518

There is a fault somewhere which is making the BEM loose its earth connection, most likely compounded by a so-so battery giving less than ordinary voltage level. I have connected external battery jumper kits to rule out the battery so now its only the module left to test/replace.

Incidently this EL one cost me $110. If these guys wont swap it or refund then it will have to go on the For Sale section.
It is possible to rewire the BEM connectors and use the EL BEM in an EF if you are stuck with it.
I'm sure it can, but all 3 plugs are in different locations and use different numbers of pins (on first comparison side by side) also the factory loom for the top plug puts it above the trim panel under the instrument cluster and would need to be extended. It will be easier to just get the correct module I think.
Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 10:30 am 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 10126

Joined: 5th Nov 2004

Gallery: 4 images

Ride: EF Gli Ghia, XP Fairmont

Location: Perth
WA, Australia

just head back and swap it over for an EF one ...

 

_________________

Owning 1 of 67612 EF GLi Sedans made
FACT: "Chuck Norris owns the greatest Poker Face of all-time. It helped him win the 1983 World Series of Poker despite him holding just a Joker, a Get out of Jail Free Monopoly card, a 2 of clubs, 7 of spades and a green #4 card from the game Uno."

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 11:44 am 
Technical Contributor
Offline
User avatar

Age: 34

Posts: 823

Joined: 6th Nov 2004

Gallery: 9 images

Ride: BF Falcon SR

Location: Perth
WA, Australia

It looks like a EF High series one...

Where the EL high series green as well?

I am assuming that if they were then it is a different plug.

 

_________________

Proud owner of one of very few BF SR manual (June 06 build) :)

Nothing really says thankyou like a dollar in the waistband

[BLEMIN]

http://www.cardomain.com/ride/782173

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 11:46 am 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 10126

Joined: 5th Nov 2004

Gallery: 4 images

Ride: EF Gli Ghia, XP Fairmont

Location: Perth
WA, Australia

yes they were both green but the EL's have the plugs on the side where as the EF's are on the top and bottom! Definately an EL one!!

 

_________________

Owning 1 of 67612 EF GLi Sedans made
FACT: "Chuck Norris owns the greatest Poker Face of all-time. It helped him win the 1983 World Series of Poker despite him holding just a Joker, a Get out of Jail Free Monopoly card, a 2 of clubs, 7 of spades and a green #4 card from the game Uno."

Top
 Profile  
 
 
Posted: Thu Jan 25, 2007 11:48 am 
Technical Contributor
Offline
User avatar

Age: 33

Posts: 5858

Joined: 5th Nov 2004

Gallery: 8 images

Ride: '95 EF's

Location: Leederville
WA, Australia

Ugly Igley wrote:
It looks like a EF High series one...

Where the EL high series green as well?

I am assuming that if they were then it is a different plug.


bloody BA owners :roll:

 

_________________

R.I.P. Scotty

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 22 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Mon Dec 11, 2017 11:47 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names