Fordmods Logo

Another EF miss problem...YES I have searched..alot 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: Another EF miss problem...YES I have searched..alot
Posted: Wed Jun 25, 2008 4:28 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 11th Jun 2007

Location: brisse
QLD, Australia

I have a 96 EFII and have been having missing problems for a little while. I have spent 2 weeks searching this forum and can't find anything.

Car has done just over 200k. The miss happens on more than half throttle. It is a definite miss that happens none stop until the throttle is released to below half. Use of less than half throttle is fine, take off is fine. Fuel consumption hasn't changed. Idle in gear is a bit low, around 500rpm but does not stall. Idle in park or neutral is fine. Problem happens when it is cold and hot.

Items that have been changed are
~leads 10000km old
~plugs less than 5000km old
~coil pack brand new- below half throttle the car is better but has not helped the miss
~fuel filer less than 500km old
~Idle speed control motor 1 year old

Any help would be greatly appreciated.

 

_________________

No that couldn't have been ME officer

Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 4:41 pm 
Getting Side Ways
Offline

Age: 31

Posts: 2337

Joined: 25th Apr 2008

Ride: Boxcar Love

Location: Brisbane
QLD, Australia

I had similar things on another car, and i changed all the s**t you have.

It turned out to be the injectors. If they are full of s**t, or just not cycling properly (likely at 200klms) then they will do similar things.

Maybe look at getting them reconditond. Its about $160 last time i did it.

 

_________________

Commodore australia's favorite car??? What a load of s**t
Image

Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 4:44 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

change your fuel filter again.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 4:54 pm 
Oompa Loompa
Offline

Age: 28

Posts: 36

Joined: 31st Mar 2007

Location: Adelaide
SA, Australia

just a suggestion... give your throttle body a good blast out with some carby cleaner
Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 4:56 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 11th Jun 2007

Location: brisse
QLD, Australia

dc_todd what would changing the filter again do? The miss happened before and after the filter change.

pimp_ltd thanks for that. That the way i'm leaning

 

_________________

No that couldn't have been ME officer

Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 5:38 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 423

Joined: 17th May 2007

I cleaned my fuel rail out a while back on my EF which has done 200k, man there was a heap of crap in it. It may be worth a try, I say fuel rail and injector clean
Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 5:40 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 11th Jun 2007

Location: brisse
QLD, Australia

Thanks for the help everyone.

 

_________________

No that couldn't have been ME officer

Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 9:19 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 824

Joined: 10th May 2007

Ride: Xr6 Turbo

Location: Melbourne
VIC, Australia

injectors.

 

_________________


Previous cars


1995 ef futura - nothing special
2003 xr6 turbo 5 -speed 307rwkw

Top
 Profile  
 
 
Posted: Wed Jun 25, 2008 9:52 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

I've had new fuel filters crap out, and just figured it may be the case here, but with the extra info, withdraw my inital suggestion.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
Posted: Thu Jun 26, 2008 1:33 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 4326

Joined: 30th Oct 2006

Gallery: 18 images

Ride: Envi EF

Location: Grafton
NSW, Australia

Fuel rail and injectors is my vote.

 

_________________

>>>EF Futura T build<<<

Top
 Profile  
 
 
Posted: Thu Jun 26, 2008 8:15 pm 
Smokin em up
Offline

Age: 28

Posts: 226

Joined: 8th May 2007

Ride: EF Falcon

Location: Sydney
NSW, Australia

well ive got same problem exepct ive replaced injectors, coolent temp sensor, fuel regulator, leads, plugs, coil pack, fuel filter and bump, im going to give the oxygen sensor a go next, also could be crank angle sensor, but ive have exactly same problem
Top
 Profile  
 
 
Posted: Thu Jun 26, 2008 8:18 pm 
Getting Side Ways
Offline

Age: 48

Posts: 1061

Joined: 7th Sep 2007

Gallery: 3 images

Ride: BF3 Egas wag SY AWD Terry Ghia

Location: Brookfield
VIC, Australia

injectors my bet. mine did the same and got better after a professional reco

 

_________________

BF3 Egas XT Wagon
SY Territory Ghia AWD 6spA :))

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names