Fordmods Logo

my ed ford wont start 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: my ed ford wont start
Posted: Thu Oct 03, 2013 8:50 am 
Fordmods Newbie
Offline

Age: 40

Posts: 3

Joined: 2nd Oct 2013

Ride: ed ford

Location: adelaide
SA, Australia

yesterday i was driving my ed ford and it suddenly staled and now it wont start again. i have plenty of petrol and the batterie is only a few months old, it feels likeit wants to start but just wont kick over. anyone have any ideas ?
Top
 Profile  
 
 
 Post subject: Re: my ed ford wont start
Posted: Thu Oct 03, 2013 9:05 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 849

Joined: 3rd Jan 2011

Gallery: 1 images

Ride: Subaru Liberty RX Wagon MY03

Location: North Richmond
NSW, Australia

If you mean the starter spins freely and the car won't go, check if it is getting spark. If not could be coil, TFI module or distributor faults.

Also check if it is getting fuel. The fuel pump may have called it quits. Can you hear it priming before you hit the starter?

 

_________________

Current ride: MY03 Liberty RX Wagon
EBII S-XR6, Now 5 speed. Moved on to greener pastures...

Top
 Profile  
 
 
 Post subject: Re: my ed ford wont start
Posted: Thu Oct 03, 2013 9:17 am 
Fordmods Newbie
Offline

Age: 40

Posts: 3

Joined: 2nd Oct 2013

Ride: ed ford

Location: adelaide
SA, Australia

i can hear it priming but it just wont kick over, i had the same thing happen with an ea ford and it ended up being the distributor but not sure if it is the same problem.
Top
 Profile  
 
 
 Post subject: Re: my ed ford wont start
Posted: Thu Oct 03, 2013 7:15 pm 
Fordmods Newbie
Offline

Age: 40

Posts: 3

Joined: 2nd Oct 2013

Ride: ed ford

Location: adelaide
SA, Australia

it started today for about 2 minutes but then cut out again and would not restart.
Top
 Profile  
 
 
 Post subject: Re: my ed ford wont start
Posted: Sat Oct 05, 2013 6:15 pm 
Stock as a Rock
Offline
User avatar

Age: 25

Posts: 164

Joined: 1st Jan 2010

Ride: EF manual Monty

Location: canberra
ACT, Australia

I would be inclined to say dodgy coil

 

_________________

R.I.P My red beast :(

Top
 Profile  
 
 
 Post subject: Re: my ed ford wont start
Posted: Sat Oct 05, 2013 8:29 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2753

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

fal98con wrote:
I would be inclined to say dodgy coil



yeah .. if it stared dead cold then eitha coil or tfi unit [part on dizzy]
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 5:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names