Fordmods Logo

climate control jammed 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: climate control jammed
Posted: Mon Aug 02, 2010 6:49 pm 
Getting Side Ways
Offline

Age: 50

Posts: 504

Joined: 2nd Dec 2006

Ride: EF wagoon

Location: perth
WA, Australia

When i start my ef fairmont the climate control flashes twice and then just sits on, as though i have hit the vents button. No fans, no noise, no nothing. None of the buttons will do anything so i can't do a diagnostic.
I had a search but can't find a solution to this problem anywhere. Has anyone got any ideas??

 

_________________

EF GLi Wagoon
Grandpa Spec

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Mon Aug 02, 2010 7:20 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Remove the Climate control module itself.
(check bulbs)
Get a set of small screwdrivers and open it carefully.

holding it face down, undo the LCD circuit board screws and gently lift it out. (otherwise you'll drop all the buttons and have to remember where they go)

Clean the Contacts with a Medi-Swab.
Now inspect the Contact pins (the ones that connect the LCD to the Logic board) most likely you'll see there's some rub marks on the solder and MAY have shorted out a few pins... RE-solder these or scratch between the pins to clear them up.

The housing rubs on these solder points and can cause this issue.
The other thing is the plugs on the back of the unit, I think another member (snap) or known as Ray, has found there can be a contact problem with the actual main harness.

Hope this helps.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Sun Aug 15, 2010 3:53 pm 
Getting Side Ways
Offline

Age: 50

Posts: 504

Joined: 2nd Dec 2006

Ride: EF wagoon

Location: perth
WA, Australia

Krytox wrote:
Remove the Climate control module itself.
(check bulbs)
Get a set of small screwdrivers and open it carefully.

holding it face down, undo the LCD circuit board screws and gently lift it out. (otherwise you'll drop all the buttons and have to remember where they go)

Clean the Contacts with a Medi-Swab.
Now inspect the Contact pins (the ones that connect the LCD to the Logic board) most likely you'll see there's some rub marks on the solder and MAY have shorted out a few pins... RE-solder these or scratch between the pins to clear them up.

The housing rubs on these solder points and can cause this issue.
The other thing is the plugs on the back of the unit, I think another member (snap) or known as Ray, has found there can be a contact problem with the actual main harness.

Hope this helps.


I tried this and stil the same. :?
Anyone got any other ideas????
This has got me stumped. :?: :?: :?:

 

_________________

EF GLi Wagoon
Grandpa Spec

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Sun Aug 15, 2010 5:02 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2450

Joined: 5th Nov 2004

Gallery: 1 images

Ride: NL V8 Fairlane

Location: Sydney
NSW, Australia

No fan comes on at all? The fan controller may be stuffed. Pull the glovebox out and you should be able to access it there. It's three screws. If it's not that, maybe the fan itself.

 

_________________

There are 10 types of people in this world.
Those who know binary and those who don't.

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Sun Aug 15, 2010 7:28 pm 
Getting Side Ways
Offline

Age: 50

Posts: 504

Joined: 2nd Dec 2006

Ride: EF wagoon

Location: perth
WA, Australia

One Drone wrote:
No fan comes on at all? The fan controller may be stuffed. Pull the glovebox out and you should be able to access it there. It's three screws. If it's not that, maybe the fan itself.


when i unplug the cc panel if i get it in the right spot as the plug is lmost disconected the fan will come on. It seems like something is jamming the system. I can't even get it to go into diagnostic mode?

 

_________________

EF GLi Wagoon
Grandpa Spec

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Fri Sep 03, 2010 7:28 pm 
Getting Side Ways
Offline

Age: 34

Posts: 638

Joined: 6th Nov 2004

Ride: 1994 Ford EF Fairmont Ghia Sedan

Location: Melbourne
VIC, Australia

I have a similar problem with my dads car.

Climate control will flash 3 times and then stay on. It is stuck on 22 degrees. there is only 2 buttons that work, off and auto. The fan does work (on auto mode) as well heater but also no air con.

I have pulled apart the unit a few time and looked all over the circuit boards and there is no shorts or broken circuits.

Any ideas?

 

_________________

1994 ford fairmont ghia - Currently 302 with T5 - Work in progress :P

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Fri Sep 03, 2010 9:04 pm 
Stock as a Rock
Offline
User avatar

Posts: 108

Joined: 12th Jun 2010

Ride: El falcon

Location: melbourne
VIC, Australia

maybe a dry solder joint?

 

_________________

I enjoy the symphony of mechanical harmony, :lol:

EL build thread
Turbo DOHC - AU front suspension - AU IRS - T56 - xr kit
the-garage-f53/bbqburners-daily-turned-toy-d-t93182.html

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Fri Sep 03, 2010 9:10 pm 
Getting Side Ways
Offline

Age: 34

Posts: 638

Joined: 6th Nov 2004

Ride: 1994 Ford EF Fairmont Ghia Sedan

Location: Melbourne
VIC, Australia

thought that too.

I have spent hours on this. Even took in to the office and looked under the microscope at ALL the solder points :(

 

_________________

1994 ford fairmont ghia - Currently 302 with T5 - Work in progress :P

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Sat Sep 04, 2010 10:13 pm 
Getting Side Ways
Offline

Age: 34

Posts: 638

Joined: 6th Nov 2004

Ride: 1994 Ford EF Fairmont Ghia Sedan

Location: Melbourne
VIC, Australia

*bump*

Is now gone to 4 flashes.

Going to spend some time tomorrow going through all the vaccum lines

 

_________________

1994 ford fairmont ghia - Currently 302 with T5 - Work in progress :P

Top
 Profile  
 
 
 Post subject: Re: climate control jammed
Posted: Sun Sep 05, 2010 2:05 am 
Getting Side Ways
Offline

Age: 34

Posts: 638

Joined: 6th Nov 2004

Ride: 1994 Ford EF Fairmont Ghia Sedan

Location: Melbourne
VIC, Australia

ok fixed the flashing issue which is ford way of saying "look at me i THINK i have a problem"

It passed the self-test about 10 times. Mode button works straight away. Auto and Off buttons work but have a 2-3 sec delay. No other button works. Changing the modes it made all the noises that it should be making but low and behold when i actually checked the floor vent, it not moving :shock:

Will have to start to pull apart the engine bay tomorrow and see if i can find where the vac leak is :cry:

 

_________________

1994 ford fairmont ghia - Currently 302 with T5 - Work in progress :P

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 4:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names