Fordmods Logo

Turbo Not Spining On idle ???? 

 

Page 2 of 2 [ 28 posts ] Go to page Previous  1, 2

 
Posted: Sun Sep 23, 2007 7:38 pm 
Fordmods Newbie
Offline

Age: 28

Posts: 7

Joined: 1st Sep 2007

Ride: au xr6

Location: mudgee
NSW, Australia

the to4b shuldnt hav truble spooling it isnt a huge turbo,id give it a bit of a look ova,

 

_________________

AU XR6 5spd full mandrell bent extractors and 3inch system fram filter
superlow kingsprings in front super superlow
kingsprings in rear

Top
 Profile  
 
 
Posted: Sun Sep 23, 2007 7:41 pm 
Stock as a Rock
Offline

Posts: 145

Joined: 21st Mar 2007

Ride: Ea 5spd

Location: Melbourne
VIC, Australia

well im not very expericned with turbo's i guess thats my fault would it be worth reco my turbo or buy another one ( brand new )
Top
 Profile  
 
 
Posted: Sun Sep 23, 2007 8:32 pm 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

get it seviced and it should be fine after that

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
Posted: Sun Sep 23, 2007 9:28 pm 
Fordmods Newbie
Offline

Age: 28

Posts: 7

Joined: 1st Sep 2007

Ride: au xr6

Location: mudgee
NSW, Australia

i culdnt say how much the reco wuld cost but it wuld prob be a lot cheaper than a new turbo,id look for a shop that wuld eitha reco or swap yours for a reco,i wuldnt worry about changing maker if u set up for the t04

 

_________________

AU XR6 5spd full mandrell bent extractors and 3inch system fram filter
superlow kingsprings in front super superlow
kingsprings in rear

Top
 Profile  
 
 
Posted: Sun Sep 23, 2007 11:54 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

T04's are cheap to overhaul...It won't be ball baearing ....

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
Posted: Mon Sep 24, 2007 3:36 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 1063

Joined: 22nd Aug 2006

Gallery: 20 images

Ride: FG XR8, F6 F6 ute, XR5T, Capri

Location: Perth
WA, Australia

i rebuild a t04b/e

full clean & balance / new compressor plate / front turbine and some other stuff - $400 from turbotech in perth

oil seal kit - $90

if its bush bearing and you are willing to have a go at it, then you'll be laughing at the money you save DIY rebuild
Top
 Profile  
 
 
Posted: Mon Sep 24, 2007 9:29 am 
Stock as a Rock
Offline

Posts: 145

Joined: 21st Mar 2007

Ride: Ea 5spd

Location: Melbourne
VIC, Australia

how hard is it to put new seals in it

and what about the fin damage on the front housing would that still affect the turbo from working correctly
Top
 Profile  
 
 
Posted: Mon Sep 24, 2007 12:05 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 1063

Joined: 22nd Aug 2006

Gallery: 20 images

Ride: FG XR8, F6 F6 ute, XR5T, Capri

Location: Perth
WA, Australia

the hardest part was finding pliers/circlip pliers to put the tiny circlips in... no place had them... but luckily i remembered i had a pair of needlenose pliers that had a tiny end

basically after taking the turbo apart, all you have to change 2 bronze 'seals' held in by 2 circlips each.

in the $90 kit you will get a new bearing, but in a $130 kit you get the middle spinner bit too.


so is the front housing damaged or the front turbine?
if its the turbine, ill try to find the invoice i had, to see the cost of a new front turbine
Top
 Profile  
 
 
Posted: Mon Sep 24, 2007 12:15 pm 
Stock as a Rock
Offline

Posts: 145

Joined: 21st Mar 2007

Ride: Ea 5spd

Location: Melbourne
VIC, Australia

i spoke to a few turbo places today and there said that the turbo not spining on idel is normal

the front blades are a little nicked but not to bad from what the turbo place said when i showed them

and ive had a j pipe made the the stadarnd exhasut flange could that be casuing poor flow and stopping me from hitting booost i got like 1-2 psi when i was at like 4000 revss ???
Top
 Profile  
 
 
Posted: Mon Sep 24, 2007 7:53 pm 
Getting Side Ways
Offline

Posts: 539

Joined: 30th Nov 2004

Location: Melbourne
VIC, Australia

can you tell us your full setup, hard to picture what is going on when all we know is you have a to4b ....

have you checked area's after your turbo for any pressure loss ? such as intake/cooler piping ?
Top
 Profile  
 
 
Posted: Mon Sep 24, 2007 8:17 pm 
Getting Side Ways
Offline

Age: 34

Posts: 3406

Joined: 7th Feb 2005

Ride: AU2 Ute

Location: melbourne
VIC, Australia

Are you driving the car when trying to make boost or just revving it?
Top
 Profile  
 
 
Posted: Tue Sep 25, 2007 10:26 am 
Getting Side Ways
Offline

Age: 33

Posts: 868

Joined: 23rd Sep 2005

Ride: eb falcon

Location: kadina
SA, Australia

Sik_Cordz wrote:
i spoke to a few turbo places today and there said that the turbo not spining on idel is normal

id beg to differ on that point...

heres an example, that i have proof of. The example used a gt30 turbo, and a 3l 2jz engine, std cams.. idle speed of 900rpm from memory. Using a turbine speed sensor, it showed that the turbo was spinning at 6000rpm, while engine idling...

mate, if yours isnt spinning, it means there is some serious drag involved.. i wouldnt think that a switch from ball bearing to bush bearing would result in a 6000rpm drop in speed at idle??

 

_________________

EB 4L, 8.4:1, R154, GT4202r, 4in exhaust, Greenslade Engineering exhaust manifold, plenum chamber, 90mm throttle, Garrett W2A cooler, Surecam custom, autronic SM4, Bosch 120lb, Crane HI-6, LX-92, LM-1, Turbosmart Reg, 2x bosch 044, turbosmart 48 gate. 470kw+ @ 18PSI

Top
 Profile  
 
 
Posted: Sun Sep 30, 2007 9:12 pm 
Stock as a Rock
Offline

Posts: 149

Joined: 28th Sep 2007

Power: 192 rwkw

Location: kadina
SA, Australia

ebs_4l wrote:
Sik_Cordz wrote:
i spoke to a few turbo places today and there said that the turbo not spining on idel is normal

id beg to differ on that point...

heres an example, that i have proof of. The example used a gt30 turbo, and a 3l 2jz engine, std cams.. idle speed of 900rpm from memory. Using a turbine speed sensor, it showed that the turbo was spinning at 6000rpm, while engine idling...

mate, if yours isnt spinning, it means there is some serious drag involved.. i wouldnt think that a switch from ball bearing to bush bearing would result in a 6000rpm drop in speed at idle??


i tend to agree with eb 4l here, i have a plain bearing air research t4 in my el and it spins at idle, not 6000rpm but spinnin none the less
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 28 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 5:20 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names