Fordmods Logo

Fordmods Advertising

2003 Zetec Ford Focus problem 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: 2003 Zetec Ford Focus problem
Posted: Thu Nov 24, 2011 6:25 pm 
Oompa Loompa
Offline

Posts: 33

Joined: 28th Nov 2004

Location: melbourne
VIC, Australia

Hey,

2003 Ford Focus is giving me the s**t.

Idles fine but when you give it some gas just above idle it stumbles around 1500rpm. Above this its fine. Sometimes it stalls when taking off from idle.

Replaced coil, leads, plugs, fuel pump, swapped over maf sensor but problem still exists. Compression is fine.

Started to throw a law maf voltage code on both mafs now.

Anyone know what the issue can be??

Thanks.
Top
 Profile  
 
 
 Post subject: Re: 2003 Zetec Ford Focus problem
Posted: Thu Nov 24, 2011 7:14 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 2815

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

at this point id be looking for dodgy wiring or a faulty ECU,

 

_________________

Because i can.

Top
 Profile  
 
 
 Post subject: Re: 2003 Zetec Ford Focus problem
Posted: Thu Nov 24, 2011 8:06 pm 
Oompa Loompa
Offline

Posts: 33

Joined: 28th Nov 2004

Location: melbourne
VIC, Australia

I thought it was fixed yesterday as it worked perfectly yesterday and this morning went back to normal.

It's a mates car so is there common places the wiring may be faulty or ways to determine the ecu to faulty? It's still logging fault codes.

We got a replacement maf which came with its own air intake pipe. We got them mxed up and one of them had a breather hole and the other didnt. We could not see if the car we have has a breather hose, is there meant to be one?

Thanks
Top
 Profile  
 
 
 Post subject: Re: 2003 Zetec Ford Focus problem
Posted: Fri Nov 25, 2011 10:37 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 2815

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

try checking the wiring of any sensor that is logging a fault code

 

_________________

Because i can.

Top
 Profile  
 
 
 Post subject: Re: 2003 Zetec Ford Focus problem
Posted: Thu Dec 01, 2011 7:36 pm 
Oompa Loompa
Offline

Posts: 33

Joined: 28th Nov 2004

Location: melbourne
VIC, Australia

New fuel pump, filter, new maf (no longer registering a fault code, and injectors were cleaned.

WTF???

What else can it be?? Is there something missing???
Top
 Profile  
 
 
 Post subject: Re: 2003 Zetec Ford Focus problem
Posted: Thu Dec 01, 2011 10:55 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 2815

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

ecu maybe? youve replaced most of everything else that could be the problem

 

_________________

Because i can.

Top
 Profile  
 
 
 Post subject: Re: 2003 Zetec Ford Focus problem
Posted: Fri Dec 02, 2011 1:37 am 
Oompa Loompa
Offline

Posts: 33

Joined: 28th Nov 2004

Location: melbourne
VIC, Australia

ecu a common prob on the focus?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Nov 26, 2014 8:50 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names