Fordmods Logo

Lights do not work on parkers or low beam, work on auto 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 1:52 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 13

Joined: 21st Apr 2011

Ride: Ford BF XR6

Location: Rokeby
VIC, Australia

Hi everyone,

I have a 2006 BF falcon XR6 and the lights don't work.

It only started yesterday, turn the lights on to parkers, nothing works. Turn the lights on to low beam nothing works, flash the high beam and the high beam lights work. If turn the light switch to auto and cover up the light sensor on the dash they all work fine.

I have replaced all the light globes recently to performance globes from narva, have checked the fuses and relays.

I doubt this is my problem, think my problem is at the light stalk itself, what I am wanting to know is has anyone had the same problem and how they fixed it, ie: replaced the stalk....

Any input would help.
Thanks
Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 3:19 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 13

Joined: 21st Apr 2011

Ride: Ford BF XR6

Location: Rokeby
VIC, Australia

Yeah might have to, wouldn't of thought it would the globes, they have been in well over two months and not a single fault.

Going by the wiring diagram that I have it seems to show that they are all on the one circuit

Anyway thanks very much for your help, will try and see.
Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 5:28 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

I bet my left nut the stalk needs replacing.
A bit of a pain in the a** job unfortunately.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 6:15 pm 
Getting Side Ways
Offline
User avatar

Posts: 450

Joined: 24th Jan 2009

Ride: BF wagon

Location: western sydney
NSW, Australia

It will be the wires inside the stalk have broken. (i had same happen to me) remove the back plate from the stalk and you will see 4 or 5 cut wires. You can replace the stalk or do what i did, this involves lenghthening all cut wires and resoldering. this was a cheap and easy fix. Took around 1 hour to do and havent had any issues since.
Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 6:31 pm 
Oompa Loompa
Offline

Age: 36

Posts: 48

Joined: 19th May 2006

Ride: BF GT-P

Location: Wodonga
VIC, Australia

Yep it's the stalk. I had mine replaced under warranty when car was less than 3 yrs old. Mine failed at night, had headlights on, put right indicator on lights began flashing opposite to indicator, turned indicator off, lights went out, turned lights to auto no problem. Very common problem with ba/f falcons.

 

_________________

THERE'S NOTHING SO GREAT AS A THUMPING V8

Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 7:09 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

xbcoupe351 wrote:
Yep it's the stalk. ...... Very common problem with ba/f falcons.


Only those with auto light setting.

The stalks are the same Ford have used from like EF at least. back then there was no headlight or auto light wires in the stalk. long stroy short stalk not big enough for all the wires needed now, so they eventually wear through. Depending which wire wears through depends on the problem you get.

For me, the auto wire wore through. I had all normal functions but no auto lights.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 10:10 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 13

Joined: 21st Apr 2011

Ride: Ford BF XR6

Location: Rokeby
VIC, Australia

Thanks all for the posts will have to do some investigating

Will be back to see how I go.
Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Sun Jun 24, 2012 10:26 pm 
Parts Gopher
Offline

Age: 32

Posts: 66

Joined: 15th Nov 2011

Gallery: 2 images

Ride: ford 1992 eb s

Location: south morang
VIC, Australia

Definitely will need steering stalks.
My bf gt-p did the same interior light on dash didn't work
and all outside lights did. Wiggled the light stalk and the dash lights lit up.
I swapped the steering stalk from a ba xr and was fine after that.
Try eBay or wreckers as new is $250+ from memory.
Cheers
Daniel

 

_________________

new ride: 96 EF fairmont ghia 5.slow, quad pipe exhaust, full custom eb ghia interior, el gt steering wheel, el xr front and full genuine ticky kit. and its a 5 speed manual. with sunroof, and mods to come.

Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Mon Jun 25, 2012 8:07 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 13

Joined: 21st Apr 2011

Ride: Ford BF XR6

Location: Rokeby
VIC, Australia

Looked at all my fuses tonight and couldn't find anything wrong with them

Tried to look up the steering column to see the wire contacts, but it was a bit hard.

I looked on eBay and for a brand new one is $395, will go and see ford tomorrow to price one up.

Tempted to do it myself, just gotta be careful around the airbag, they say if the battery is fully disconnected it should be all safe, would there be anything else i would need to do.
Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Mon Jun 25, 2012 8:40 pm 
Parts Gopher
Offline

Age: 32

Posts: 66

Joined: 15th Nov 2011

Gallery: 2 images

Ride: ford 1992 eb s

Location: south morang
VIC, Australia

No that's it, disconnect negative lead from battery and then
you can remove it.
If its ba/bf should be t30 torx bit that fits.
If fg has a little hole at bottom of steering wheel to put flat blade
in and push.
It's really pretty easy.

 

_________________

new ride: 96 EF fairmont ghia 5.slow, quad pipe exhaust, full custom eb ghia interior, el gt steering wheel, el xr front and full genuine ticky kit. and its a 5 speed manual. with sunroof, and mods to come.

Top
 Profile  
 
 
 Post subject: Re: Lights do not work on parkers or low beam, work on auto
Posted: Mon Jun 25, 2012 8:58 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 13

Joined: 21st Apr 2011

Ride: Ford BF XR6

Location: Rokeby
VIC, Australia

Yeah I think if I followed the car manual that I have for it I should be pretty right.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 7:38 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names