Fordmods Logo

Wheels not spinning when i dropped the clutch(clutch NEW) 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Wheels not spinning when i dropped the clutch(clutch NEW)
Posted: Wed Mar 22, 2017 8:21 pm 
Fordmods Newbie
Offline

Age: 18

Posts: 1

Joined: 22nd Mar 2017

Ride: Ford falcon AU II XR6 VCT Manual

Location: Adeliade
SA, Australia

Au xr6 manual

How's it going every one has and issue today when I dropped the clutch, I had absolutely no wheel spin at all. Car just seemed to take off normal.This is unusual as I had a heavy duty clutch installed last year. I'm still able to get a little wheel spin when I changed into in second which has as ways been normal. Not sure what the problem could be hopping its not clutch slipping. Also when I drive hard I can get an odd smell coming from the car doesn't smell like clutch. Tho.

What needs to be done New clutch?? Adjust the cable?? Any advice would be appreciated cheers
Top
 Profile  
 
 
 Post subject: Re: Wheels not spinning when i dropped the clutch(clutch NEW)
Posted: Thu Mar 23, 2017 5:47 pm 
Oompa Loompa
Offline

Posts: 41

Joined: 16th Feb 2010

Ride: Ford Territory and Falcon RTV

Location: None of your business
NSW, Australia

Congratulations.

Your clutch is controlling the torque transfer to your wheels, and your tyres are providing traction.

Both things that they are designed to do. So why are you trying to initiate wheel spin and why do you think you have a problem because it isn't occurring.

DH :roll:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Oct 22, 2017 8:33 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names