Fordmods Logo

odd obd2 issues with BA6 at 250kk; no MIL on ol_fault 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: odd obd2 issues with BA6 at 250kk; no MIL on ol_fault
Posted: Wed Mar 29, 2017 5:23 pm 
Fordmods Newbie
Offline

Age: 71

Posts: 3

Joined: 29th Mar 2017

Ride: Ford ba '04; bf lpg '05

Location: melbourne
VIC, Australia

I'm a newbie so hope this is the appropriate forum. There are some oddball things happening with the BA that I need help with. Prob #1 is that 0l_fault was detected some months ago with O2 volts stuck high (.9v) without flagging error codes (why not?) on a hot idling engine. Deciding the O2 sensor was the likely fault after 250kk, I replaced the O2 sensor (now Bosch), and did a reset, but it's made no difference after half a dozen city work trips. I'm using Autel GS350 on the OBD. For some reason MAP, TP, CATEMP, and AAT are all missing although the tool detects CAN OBD2, J1850, ISO 9141-2, and KWP2000. I've also used it on the BF and it shows the proper PID results there. All the docs and threads I've read indicate the BA and BF are identical in OBD2 implementation, so why the missing PID outputs?
Since the CAN bus is not coughing up data for other critical sensors, I can't tell if one of them is faulty, but if there is a prob with one of them, why wouldn't MIL be set??? Meanwhile the BA is being used daily without obvious issues, although it does seem excessively thirsty and also smelly. What am I missing? Something is wrong here surely? Just remembered; when I gave the throttle a decent blast, the o2 volts did drop down briefly and the engine coughed and spluttered for a bit, then returned to former. That's probably significant, but not to me. Heeeelp.
Top
 Profile  
 
 
 Post subject: Re: odd obd2 issues with BA6 at 250kk; no MIL on ol_fault
Posted: Fri Mar 31, 2017 12:14 pm 
Stock as a Rock
Offline

Age: 64

Posts: 142

Joined: 4th Feb 2016

Location: australia
VIC, Australia

Ford don't like their check engine light coming on, and you will have to do a number of drive cycles before it will. Unless there is a major problem that effects the cat, or other systems, it will store the code in the continuous monitoring section. I have not heard of an autel gs 350 and when I typed it up in the autel web site, it came up empty, so to your problem, I would try another scan tool.
Top
 Profile  
 
 
 Post subject: Re: odd obd2 issues with BA6 at 250kk; no MIL on ol_fault
Posted: Fri Mar 31, 2017 6:16 pm 
Fordmods Newbie
Offline

Age: 71

Posts: 3

Joined: 29th Mar 2017

Ride: Ford ba '04; bf lpg '05

Location: melbourne
VIC, Australia

Sorry, it's a maxscan gs500 from Autel, not 350
Top
 Profile  
 
 
 Post subject: Re: odd obd2 issues with BA6 at 250kk; no MIL on ol_fault
Posted: Sun Apr 02, 2017 11:04 pm 
Stock as a Rock
Offline

Age: 64

Posts: 142

Joined: 4th Feb 2016

Location: australia
VIC, Australia

mate it is a 48$ dollar code reader, I know it says it can read live data but it is probably not worth a pinch of goat s**t, very basic stuff.
Top
 Profile  
 
 
 Post subject: Re: odd obd2 issues with BA6 at 250kk; no MIL on ol_fault
Posted: Wed Apr 12, 2017 6:05 pm 
Fordmods Newbie
Offline

Age: 71

Posts: 3

Joined: 29th Mar 2017

Ride: Ford ba '04; bf lpg '05

Location: melbourne
VIC, Australia

Now got an elm327 wifi dongle mated to iPhone running Forscan lite (for iphone). Magic stuff, but still on the learning curve. Now got a collection of dtcs related to o2 not switching, none of which has set MIL, so piles of things to check. I mainly only have access to the BA at weekends as its a daily work car. If u didn't know better u would think it was running ok.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 9:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names