Fordmods Logo

FG Falcon with System Comms Fault 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: FG Falcon with System Comms Fault
Posted: Mon Jan 30, 2017 1:39 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 30th Jan 2017

Ride: Falcon FG G6E turbo

Location: Canberra
ACT, Australia

My 2012 G6E turbo has developed a problem with the Internal Command Centre so my dealer tells me. I'm getting a "system comms fault" message when I start the car. The Command Centre console is blank and the aircon is definitely not working (Bluetooth and radio also not working). I have replaced the battery and I'm now waiting for Ford to deliver a new ICC from Melbourne to Canberra - 2.5 weeks so far (I think it's been transported on a silk cushion on the back of a wombat). I'd like to find out if anyone else has had this problem and if this was the solution. Thanks in advance.
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Sun Feb 05, 2017 11:06 am 
Fordmods Newbie
Offline

Posts: 1

Joined: 5th Feb 2017

Ride: Ford Falcon 2008

Location: Sydney
NSW, Australia

I am currently experiencing the exact same problem starting from last night....

"system comms fault" message when I start the engine...
The command centre console is blank, aircon and radio functions are not working....

I was assuming it was an electrical problem maybe a fuse...

Would appreciate your feedback...
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Sun Feb 05, 2017 12:37 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 30th Jan 2017

Ride: Falcon FG G6E turbo

Location: Canberra
ACT, Australia

We've checked the fuses and replaced the battery with no improvement. With the part still somewhere between Melbourne and Canberra (still - 3 weeks + now) I'm tempted to lift the trim and check the connections to make sure everything is plugged in. I have no evidence that the dealer checked that :cry:
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Mon Feb 13, 2017 10:55 am 
Fordmods Newbie
Offline

Age: 29

Posts: 1

Joined: 13th Feb 2017

Ride: 2012 G6E Turbo

Location: Melbourne
VIC, Australia

Hey Chris,

I've got the exact same problem with the same model car, Just started today 13/02.

Did they say what the cause was?
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Mon Feb 13, 2017 1:00 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 30th Jan 2017

Ride: Falcon FG G6E turbo

Location: Canberra
ACT, Australia

No advice on the cause but I have been thinking back on issues I've had over the past 4 years. First the NAV screen went blank and the dealer recommended disconnecting and reconnecting the battery (basically a reboot) and that fixed it. Then late last year the screen went blank for all options, we recharged the battery and that was fixed. And now it's not functioning at all.
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Wed Feb 15, 2017 9:04 am 
Fordmods Newbie
Offline

Posts: 6

Joined: 30th Jan 2017

Ride: Falcon FG G6E turbo

Location: Canberra
ACT, Australia

The part has arrived!! And with its characteristic customer service, the dealer didn't reserve any time for me this week and I have to wait until next week. I'll be writing a please explain to Ford Australia when I'm sure my car is functional again.
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Wed Feb 15, 2017 9:44 am 
Fordmods Newbie
Offline

Posts: 6

Joined: 30th Jan 2017

Ride: Falcon FG G6E turbo

Location: Canberra
ACT, Australia

I would also suggest looking on Gumtree for a replacement part - Haynes have an online manual which details how to remove and replace the unit. Any decent auto-electrician should be able to do the work.
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Thu Jun 01, 2017 12:01 pm 
Fordmods Newbie
Offline

Posts: 1

Joined: 1st Jun 2017

Ride: Ford FG G6E Turbo

Location: Australia
WA, Australia

Hey Chris, I have the same problem, just wondering if the new ICC sorted and if you found the underlying issue ?
Cheers
Top
 Profile  
 
 
 Post subject: Re: FG Falcon with System Comms Fault
Posted: Fri Jun 02, 2017 10:07 am 
Fordmods Newbie
Offline

Posts: 6

Joined: 30th Jan 2017

Ride: Falcon FG G6E turbo

Location: Canberra
ACT, Australia

The replacement unit has worked like a charm. I suspect that as it's all computerised a power surge when the battery failed caused some electrical fault in the unit.

Second-hand parts are almost impossible to get for the model and it appears that new ICC units are unavailable too. The "new" unit in my car was "reconditioned" at $2500 (including labour).
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Oct 22, 2017 8:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names