Fordmods Logo

BF Mark 2 Ute Cruise control Issue 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: BF Mark 2 Ute Cruise control Issue
Posted: Tue Jun 06, 2017 12:46 am 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1231

Joined: 6th Nov 2004

Ride: 2010 Nitro Blue FG

Location: Melbourne
VIC, Australia

Hi Guys,

Long time since ive posted here. Im posting this for a mate of mine. He owns a BF MKII ute and has issues with the cruise control. Issue:- It will turn "on" but wont set a speed when you hit the "Set" button

First things first, he replaced the button set but still the same issue occurs. Is there a cruise control solenoid/actuator or control module that maybe effecting it. Can anyone shed any light on this. Im tipping its the module or cruise switch (not sure exactly what its called, if you do, please let me know)

Cheers for your help.

Hey Phong, you still around in that POS EL? Did you get home from the shops that day? ;)

 

_________________

The boogieman checks under his bed for chuck norris

Top
 Profile  
 
 
 Post subject: Re: BF Mark 2 Ute Cruise control Issue
Posted: Tue Jun 06, 2017 7:02 am 
Fordmods Junkie
Offline
User avatar

Posts: 2750

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

do your brake lights work? and yes Phong is still 'around' ... somewhere :lol:
Top
 Profile  
 
 
 Post subject: Re: BF Mark 2 Ute Cruise control Issue
Posted: Wed Jun 07, 2017 12:54 am 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1231

Joined: 6th Nov 2004

Ride: 2010 Nitro Blue FG

Location: Melbourne
VIC, Australia

Yep, brake lights all work, ironically they died earlier and have been replaced and re-wired in (correctly).

I read somewhere else that this can effect the cruise or have some kind of electrical gremlin link to it?

cheers.

 

_________________

The boogieman checks under his bed for chuck norris

Top
 Profile  
 
 
 Post subject: Re: BF Mark 2 Ute Cruise control Issue
Posted: Sun Jun 18, 2017 10:07 pm 
Technical Contributor
Offline

Posts: 492

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

check clutch switch if manual

try remove BOTH stop switches, and reset switches by pulling button out slightly then refit switch and return pedal to rest position
do the same with clutch switch (not all are able to be reset) if fitted

cruise control module is the engine computer and controls cruise by controlling throttle actuator

do you know if this has operated previously as it may not have been programmed on by ford if fitted aftermarket

are stop lights LED if so load resistor will need fitting to each side stop light circuit
Top
 Profile  
 
 
 Post subject: Re: BF Mark 2 Ute Cruise control Issue
Posted: Fri Jul 14, 2017 8:26 am 
Fordmods Newbie
Offline

Age: 76

Posts: 11

Joined: 22nd Apr 2013

Ride: DL FORD LTD

Location: Mt Martha
VIC, Australia

I had the same problem with my cruise control on my DL LTD, turned out to be what looks like a brake switch on the master cylinder. Replaced it and cruise control operates as it should.
Top
 Profile  
 
 
 Post subject: Re: BF Mark 2 Ute Cruise control Issue
Posted: Tue Oct 31, 2017 3:09 pm 
Fordmods Newbie
Offline

Age: 58

Posts: 6

Joined: 19th Aug 2015

Ride: BF LPG UTE

Location: Perth
WA, Australia

did you ever get this sorted?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:27 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names