Fordmods Logo

95 EF Battery/s 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: 95 EF Battery/s
Posted: Tue Oct 03, 2017 6:38 pm 
Fordmods Newbie
Offline

Age: 19

Posts: 1

Joined: 3rd Oct 2017

Ride: 95 Ef Falcon

Location: Taree
NSW, Australia

I got a 95 Ef and the Battery kept on dying, so I replaced it with another battery and now she's dead aswell, the only way to start it is with a jump. I've tried to let it charge by going around town. Stopped and dead battery. It jumps fine so I don't think it's the alternator.
Top
 Profile  
 
 
 Post subject: Re: 95 EF Battery/s
Posted: Tue Oct 03, 2017 8:15 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2752

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

may have to check & see if there is any load on battery when cars off ie boot light
Top
 Profile  
 
 
 Post subject: Re: 95 EF Battery/s
Posted: Wed Oct 04, 2017 10:42 am 
Oompa Loompa
Offline

Age: 27

Posts: 37

Joined: 5th Apr 2017

Ride: 2003 BA N/A XR6 ute

Location: Albury
NSW, Australia

Go to a battery shop or local SCA and get a battery test. This will include an Alternator and Starter test. I've never had an issue jumping a car with a dying alternator either, I don't see why you are writing it off as the culprit so quickly.

Example - My wife's Corolla had battery issue. Replaced with new Century. Was fine for a little while, then same issue. Put a multimeter on, parasitic draw of 3 amps. Pull fuses until it goes away, it was the radio. Still happening, get battery test and alt shows just under 13 volts. Enough to keep car running when jump started, but not enough to charge the battery at the same time. New alternator, bigger earth cable, another new battery (all the discharging and recharging caused to fail over about 4 months) and ta da. Problem solved, radio fuse back in and not a single time have I had to look at it since.

Check your parasitic draw and get your alternator tested ASAP, before you kill the new battery

 

_________________

2003 Narooma Blue XR6 ute - NOW WITH 6 SPEED! - Underdrives, Hyperflow + Terry pipe + turbo snorkel, 4490's, Venom H/F Cat, 2.5" Redback, BF Turbo T56 conversion, H/D Turbo clutch, custom tailshaft, 3.89 LSD

Top
 Profile  
 
 
 Post subject: Re: 95 EF Battery/s
Posted: Wed Oct 04, 2017 3:40 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2752

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

josh1990 wrote:

Check your parasitic draw and get your alternator tested ASAP, before you kill the new battery



I've also had a brand spanky new battery fail ina about 2 weeks. battery guy said it must be your alternator & my guy sayin nah all good? lol. turned out it was the battery & was replaced then nada after that.

but yeah get the alt/starter test done, then check for battery drain.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 3:37 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names