Fordmods Logo

Ef fairmont stalling on petrol 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Ef fairmont stalling on petrol
Posted: Thu Nov 16, 2017 11:18 am 
Stock as a Rock
Offline

Age: 30

Posts: 130

Joined: 6th Aug 2014

Ride: ford

Location: yorke peninsula
SA, Australia

Hi there

Really need your help here

Have a ef fairmont and it’s started stalling on petrol. It runs for a few seconds on petrol then stops and sometimes it won’t restart on petrol and when it does it stops after a few seconds and same again.

Sometimes it’ll just stop at idle and sometimes it’ll stop when you put foot on acc, it’s like there’s not enough fuel getting through.

The gas hasent been working so been using petrol to give it a good run and when this happened tried running in gas and it seemed ok.

Going to fit a walbro 255 fuel pump to it eventually but wondered wether to do plugs and leads as it has been a while since either were done.

Fuel pumps not very old as it’s been replaced.

It has a xr6 ecu on a std engine and till now it’s been good.



Would anyone know what’s likely wrong.

Thanks
Top
 Profile  
 
 
 Post subject: Re: Ef fairmont stalling on petrol
Posted: Thu Nov 16, 2017 3:51 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Check fuel filter. Make sure it's not completely blocked causing fuel delivery issues. Injectors could also be blocked and may need a clean and check the fuel regulator too.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Ef fairmont stalling on petrol
Posted: Thu Nov 16, 2017 6:51 pm 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 3805

Joined: 22nd Apr 2007

Gallery: 5 images

Ride: DENTED UP OLD AUT WAGON

Location: Wellington
New Zealand

I just found my 300kpa (ef xr6) fuel regulator wasn't working, along with a range of other issue in my poor old wagon... Took the fuel rail off and could blow through the regulator, so it wasn't holding pressure engine would run a bit then fade off pretty promptly...

Best idea would be stick injector cleaner in your tank - I tend to put a lot in it when tank is almost empty, then drive to the gas station and fill it. So it gets a decent go and removing the sludge and spitting it out.

Pretty sure LPG still needs spark and coil pack to be working okay, so if it's running on LPG, chances are it should keep running on petrol if it is getting the petrol into it okay.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names