Fordmods Logo

Ford AU Instrument Cluster Panel Compatiblity. 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Ford AU Instrument Cluster Panel Compatiblity.
Posted: Thu Apr 26, 2018 8:24 pm 
Getting Side Ways
Offline

Age: 59

Posts: 1056

Joined: 13th Sep 2010

Ride: Ford Falcon AU 2000 Series II

Location: Eagleby
QLD, Australia

Question regarding compatibility.

I have a Ford AU2 (Forte), build June 2000, went to the wreckers to find another one to replace mine. I found one that was basically intact but came from a Ford AU (Forte) Build February 2000, not an AU2.

I'm wondering whether the one from an AU will work as is on an AU2 or will there be a problem?

Thanks,
Peter
Top
 Profile  
 
 
 Post subject: Re: Ford AU Instrument Cluster Panel Compatiblity.
Posted: Thu Apr 26, 2018 8:34 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2831

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

bondy99 wrote:
Question regarding compatibility.

I'm wondering whether the one from an AU will work as is on an AU2 or will there be a problem?

Thanks,
Peter



Hi, my understanding is AU2/3 are compatible with the AU1 being hit & miss. have tried a AU1 in the AU2, but some parts of the cluster were NOT compatible between the two. i don't remember which parts sorry.
Top
 Profile  
 
 
 Post subject: Re: Ford AU Instrument Cluster Panel Compatiblity.
Posted: Thu Apr 26, 2018 8:44 pm 
Getting Side Ways
Offline

Age: 59

Posts: 1056

Joined: 13th Sep 2010

Ride: Ford Falcon AU 2000 Series II

Location: Eagleby
QLD, Australia

Thanks Mad2,

I'll have to see if there is an AU3, at the wreckers, all the wrecks I've seen so far have been stripped.
Top
 Profile  
 
 
 Post subject: Re: Ford AU Instrument Cluster Panel Compatiblity.
Posted: Thu Apr 26, 2018 9:56 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2831

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Top
 Profile  
 
 
 Post subject: Re: Ford AU Instrument Cluster Panel Compatiblity.
Posted: Thu Apr 26, 2018 11:40 pm 
Getting Side Ways
Offline

Age: 59

Posts: 1056

Joined: 13th Sep 2010

Ride: Ford Falcon AU 2000 Series II

Location: Eagleby
QLD, Australia

Mad2,

The problem with the one I currently have is that at night I cant read the odometer so I can check DTE. I've replaced the globes at the back of the odometer, they lit up for 2 weeks, but after that, they no longer light up, even with replacing with original and aftermarket globes.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon May 21, 2018 7:37 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names