Fordmods Logo

XG 302 HO winsor rev hunting 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: XG 302 HO winsor rev hunting
Posted: Fri Nov 29, 2019 9:10 pm 
Parts Gopher
Offline
User avatar

Age: 27

Posts: 65

Joined: 11th May 2012

Ride: 94 tickford enhanced xg ute

Location: devonport
TAS, Australia

G'day guys n gals
i have just got my hands on a 302HO XG ute and am having some issues working out the kinks.
PROBLEM: its rev hunting from the moment it starts, through out county road speeds and a little on the highway hot or cold. this is quite annoying (being an auto) when you come to traffic lights or just crawling around carparks.

SO FAR: new idle speed controller(tried disconnecting and setting idle manually too), new fuel filter, new exhaust system, cold start valve is bypassed, new intake man gasket and throttle body gaskets, replaced brake booster and replaced some perished or hard hoses to and from the manifold.

CURRENTLY: i'm at a loss atm. any ideas would be greatly appreciated. :| :mrgreen:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 16, 2019 2:33 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names