Fordmods Logo

XHII V8 WATERPUMP 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: XHII V8 WATERPUMP
Posted: Tue Sep 03, 2019 5:48 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 23rd Feb 2019

Location: dubbo
NSW, Australia

I noticed the w/p gasket leaking so decided to replace the pump while im at it, how do I remove the pulley on the pump? do I need some special tool or can I just attack those 4 bolts? I've unscrewed the 8 bolts that hold the w/p to the block but I will need that pulley.
Top
 Profile  
 
 
 Post subject: Re: XHII V8 WATERPUMP
Posted: Wed Dec 25, 2019 5:10 pm 
Oompa Loompa
Offline

Age: 54

Posts: 48

Joined: 30th May 2011

Ride: V8 XG VAN / V8 NL fairlane ghia

Location: Melbourne
VIC, Australia

You don’t
Replace the whole lot
Top
 Profile  
 
 
 Post subject: Re: XHII V8 WATERPUMP
Posted: Mon Feb 10, 2020 8:20 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 23rd Feb 2019

Location: dubbo
NSW, Australia

Cheers, Those 4 screws came off easier than I thought. your right the Pulley was on the w/p. I replaced the whole dam lot for $50. she runs a treat now.
Top
 Profile  
 
 
 Post subject: Re: XHII V8 WATERPUMP
Posted: Mon Feb 10, 2020 8:22 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 23rd Feb 2019

Location: dubbo
NSW, Australia

forgot to ask, Is there 2 Cooolant Temp sensors on the 302 windsor? there is one on the rail-drivers side just under the plenum but on the Passenger side there seems to be One inserted into the Inlet Manifold block is that a CTS? also are they the same I got a spare fuel miser one, yes there s**t but thats all I got atm.
Top
 Profile  
 
 
 Post subject: Re: XHII V8 WATERPUMP
Posted: Thu Feb 20, 2020 9:20 am 
Fordmods Newbie
Offline

Posts: 13

Joined: 23rd Feb 2019

Location: dubbo
NSW, Australia

must be the only bloke who owns an XH here
Top
 Profile  
 
 
 Post subject: Re: XHII V8 WATERPUMP
Posted: Thu Feb 20, 2020 4:23 pm 
Fordmods Junkie
Online
User avatar

Posts: 3484

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

sdomdrof wrote:
must be the only bloke who owns an XH here



sadly .... not many are on here anymore :( a few [very] sometimes pop in
Top
 Profile  
 
 
 Post subject: Re: XHII V8 WATERPUMP
Posted: Mon Feb 24, 2020 6:56 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 23rd Feb 2019

Location: dubbo
NSW, Australia

Mad2 wrote:
sdomdrof wrote:
must be the only bloke who owns an XH here



sadly .... not many are on here anymore :( a few [very] sometimes pop in


True, Im going to replace the HEGO sensors tomorrow, she threw a 172 code so I bet there both well passed there used by date.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Sep 20, 2020 9:05 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names