Fordmods Logo

Falcon ed 4.0 Sudden non start...not so uncommon 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Mon Jan 04, 2021 3:09 pm 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

New year new problems...

All worked well till 2 days go.
Since then there has been a lot of heavy rain.... just adding this detail for the more analytically minded diagnosers.

1 Today I started the car and it started very well, drove 2 m and then it went dead. Motor stopped
2 Turned the engine and it started spattering on and off but no start
3 turned a second time and it did the same
4 third time and there was no spatter. It just cranked with no ignition.
5 Checked fuel pressure....seems very good because as I undid the clip it started spitting out. Turned
the key and fuel flowed quite well. (no pressure measurement taken)
6 Took spark plug out and inserted screwdriver. Turned engine and spark was good.
7 removed fuel line and pumped 1/2 l of fuel into a bottle to see if there was water. None noticed
8 as i removed the fuel line from the rail some fuel came out of the rail. Nothing abnormal there BUT
I got wife to turn engine and it started spattering and almost started
9 reinserted fuel line and it only cranked

Fuel qty is low but no lamp turns on.

My analysis is that the ignition coil is ok
Did not test injectors as it is almost impossible they all fail at once. However the fact that it started spattering when there was NO fuel pressure is a worry.
The Distributor and module and plugs and leads were replaced with original Bosch only 3000 kms ago
The fuel pump seems to work.
Hopefully one of the more experienced members can help me out
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Mon Jan 04, 2021 6:32 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3586

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

seeing as it's been raining heavy ......... have you checked the passenger 'A' pillar base for water?. some 'may have' leaked in & run into/onto ecu.
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Mon Jan 04, 2021 6:51 pm 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

Mad2 wrote:
seeing as it's been raining heavy ......... have you checked the passenger 'A' pillar base for water?. some 'may have' leaked in & run into/onto ecu.


I never messed with the ECU...so much so I have no idea where it is. Will check the left internal passenger panel. Good call. Hope I have not fried the ECU :cry:

The fact that the car started firing when the fuel hose (and therefore fuel pressure) was disconnected. totally baffles me
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Mon Jan 04, 2021 9:20 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3586

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

brik32544 wrote:
I never messed with the ECU...so much so I have no idea where it is. Will check the left internal passenger panel. Good call. Hope I have not fried the ECU :cry:


fingers crossed it's not that.


brik32544 wrote:
The fact that the car started firing when the fuel hose (and therefore fuel pressure) was disconnected. totally baffles me



no idea on that one. but if it starts & runs on start ya bastard etc it 'maybe' fuel related.
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Wed Jan 06, 2021 1:00 pm 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

After yesterday's washout I did some more checks. Was curious about the possibility of bad fuel, but that is not the issue.
Then I looked for the ECU. It seems well hidden. There is a side kick panel on the passenger side. Is that what I need to remove?

Then, I checked what I had prematurely excluded as a problem, The injectors! Sure enough there is no flashing when I connect a noid light.... is this another clue that points to wards a fried ECU? :roll:

PS this Ford has the smartlock which has never caused me problems but through the years I read of many owners that had smartlock problems.....any hints?
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Wed Jan 06, 2021 6:50 pm 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

I found and removed the ECU. It was as dry as it should be . No water or visible condensation

I then removed the BCU which controls the smartlock and can block injectors. Tried to add photos but it seems this website lacks space or does not want to encourage photo uploads. No evident marks on the board.

Image
Photo of ECU board...looks as good as new

Image
Photo of BCU front

Image
Photo of BCU back. Note a few dust spots concentrated on a couple or resistors near connector.


I will clean it with compressed air and refit it but something tells me I am back to square one

A local mechanic said that water dropping from windscr4een on the BCU is common in tropical Australia. I carefully looked over the cases of both boards and there is not one small sign of water. Just very still dry dust from many years of sitting there.

Any way to fault find one of these boards?
Note that I have a spark and I have fuel, I just don't have a signal at the injectors

Back to you experts...
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Wed Jan 06, 2021 9:08 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3586

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

if you still have it out & loose ........ check for dry solder joints.


also did you check the connectors at the top of the ecu?
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Wed Jan 06, 2021 11:58 pm 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

Mad2 wrote:
if you still have it out & loose ........ check for dry solder joints.

I certainly did. Tomorrow I will connect it without the box and gently move some relays and components on the board

Mad2 wrote:
also did you check the connectors at the top of the ecu?

Yes and sprayed it with WD

NEW INFO

The motor turned but did not start, however, I then changed the gear from N to P and back to N and the engine started firing but did not start. This brought back to memory an event 3 weeks ago when the engine would not turn. Moved the gears back and forth and it returned to normal.

As I replaced the BCU which is orange/red I noticed another board in a blue box nearby attached to the centre console in a b**ch of a place to reach. What is that?
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Thu Jan 07, 2021 12:28 am 
Fordmods Junkie
Offline
User avatar

Posts: 3586

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

brik32544 wrote:
Mad2 wrote:
if you still have it out & loose ........ check for dry solder joints.

I certainly did. Tomorrow I will connect it without the box and gently move some relays and components on the board

Mad2 wrote:
also did you check the connectors at the top of the ecu?

Yes and sprayed it with WD

NEW INFO

The motor turned but did not start, however, I then changed the gear from N to P and back to N and the engine started firing but did not start. This brought back to memory an event 3 weeks ago when the engine would not turn. Moved the gears back and forth and it returned to normal.

As I replaced the BCU which is orange/red I noticed another board in a blue box nearby attached to the centre console in a b**ch of a place to reach. What is that?



got a pic?
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Thu Jan 07, 2021 10:17 am 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

I did some research and Ford ED and EB have a YELLOw or RED BOX which has the following code:
9330065108



FALCON / FAIRMONT EB Red / Yellow Smart Lock 9330065108
FALCON / FAIRMONT ED Red / Yellow Smart Lock 9330065108

this is the SMARTLOCK MODULE .. NOT the BEM Body Electronics module.

It seems that if the smartlock light comes on and then goes off without blinking, the smartlock module is working. Is this right?

So the other blue box must be the BEM

FALCON / FAIRMONT ED Blue - BCM 9330065059
FALCON / FAIRMONT ED Green - BCM 9330065060

Note how FORD installed 2 models (green or blue) in the same car.
Mine should be 9330065059. Will check
Top
 Profile  
 
 
 Post subject: Re: Falcon ed 4.0 Sudden non start...not so uncommon
Posted: Fri Jan 08, 2021 1:07 pm 
Oompa Loompa
Offline

Posts: 49

Joined: 21st Mar 2011

Ride: Ford Falcon ED 1994 SW

Location: sydney
NSW, Australia

It seems I had a faulty NOID light! So it may not be an electronic problem.


1) There is a signal at each injector. First when you tuen the ignition to ON and then when you click it to start

2) There is plenty of fuel at the rail. Measured at 70PSI

3) each cylinder sparks

4) the engine fires when the PUMP hose is removed! ONLY when the pump hose is removed for a couple of seconds as the fuel in the rail depleats

BACKGROUND
The car started fine a few days ago. Travelled 30 m and it stopped . Restarted and it started sputtering and then engine stopped firing
There was lots of rain in the 2 days prior.

I think I'll have to post this on a new thread :roll:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: AU3xr6Ute02, Google [Bot] and 38 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Apr 23, 2021 12:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names