Fordmods Logo

Cruise Control Not Turning/Powering on 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 12:27 pm 
Fordmods Newbie
Offline

Age: 51

Posts: 5

Joined: 5th Feb 2021

Ride: BF XR6 Ute -Manual

Location: Mudgeeraba
QLD, Australia

Hello all,

I have a BF XR6 manual that the cruise control will not turn/power on. No lights on the dash to indicate that it's on. Anyone have any ideas? I can't find a fuse anywhere. Any help will be appreicated.

Cheers,

Paul
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 7:27 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 424

Joined: 8th Jul 2009

Gallery: 2 images

Ride: BA MKII XR6

Location: Waikato
New Zealand

Doesn't have lights, just the word "cruise" in the right hand side above the odometer
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 7:30 pm 
Fordmods Newbie
Offline

Age: 51

Posts: 5

Joined: 5th Feb 2021

Ride: BF XR6 Ute -Manual

Location: Mudgeeraba
QLD, Australia

I know, but it doesn't light up when the cruise control is turned on. I've replaced the clock spring and switches already.
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 8:01 pm 
Fordmods Junkie
Online
User avatar

Posts: 3585

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

jughead0691 wrote:
I know, but it doesn't light up when the cruise control is turned on. I've replaced the clock spring and switches already.



have you fitted LED brake lights? ... do the brake lights actually work? did it have cruise control fitted from factory?
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 9:01 pm 
Fordmods Newbie
Offline

Age: 51

Posts: 5

Joined: 5th Feb 2021

Ride: BF XR6 Ute -Manual

Location: Mudgeeraba
QLD, Australia

All brake lights work and stock halogen globes fitted.
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 9:32 pm 
Fordmods Junkie
Online
User avatar

Posts: 3585

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

only other thing i can think of is the two switches on the brake pedal 'slightly' out of alignment?. one brake switch & other cruise switch.
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Fri Feb 05, 2021 10:04 pm 
Fordmods Newbie
Offline

Age: 51

Posts: 5

Joined: 5th Feb 2021

Ride: BF XR6 Ute -Manual

Location: Mudgeeraba
QLD, Australia

If those switches were misaligned, would that stop the cruise control from turning on though?
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Sat Feb 06, 2021 9:09 am 
Fordmods Junkie
Online
User avatar

Posts: 3585

Joined: 22nd Jan 2009

Ride: '03 BA Wagooon & EB Wagooons

Location: Geeelong
VIC, Australia

jughead0691 wrote:
If those switches were misaligned, would that stop the cruise control from turning on though?


that i don't actually know. just remember reading about em somewhere ages ago
Top
 Profile  
 
 
 Post subject: Re: Cruise Control Not Turning/Powering on
Posted: Sat Feb 13, 2021 10:13 pm 
Technical Contributor
Offline

Posts: 553

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

remove both brake pedal switches pull plunger out slightly to reset and refit while holding brake pedal down then pull pedal back to it's rest position do this for both switches -don't mix them or there position as this is about getting the switches to be in correct sequence

suggest scanning for codes if it continues to play up

Have tried turning on and setting cruise even if light doesn't work
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Apr 17, 2021 4:03 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names