Fordmods Logo

Premade LED instrument cluster blubs for EF/EL(No Soldering) 

 

Page 2 of 2 [ 22 posts ] Go to page Previous  1, 2

 
Posted: Fri Dec 31, 2004 4:06 pm 
Getting Side Ways
Offline
User avatar

Posts: 6168

Joined: 5th Nov 2004

how much do they cost?

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Dec 31, 2004 4:17 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3772

Joined: 5th Nov 2004

Gallery: 33 images

Ride: EL Fairmont Ghia

Location: Hobart
TAS, Australia

i heard that to much masturbating makes u blind

mitch read the first post again
Top
 Profile  
 
 
Posted: Fri Dec 31, 2004 6:03 pm 
Getting Side Ways
Offline
User avatar

Posts: 6168

Joined: 5th Nov 2004

maybe he edited the post :P
haha i just saw the link and looked there :P

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Dec 31, 2004 8:44 pm 
Stock as a Rock
Offline
User avatar

Age: 33

Posts: 107

Joined: 8th Nov 2004

Gallery: 1 images

Ride: EF II Fairmont

Location: Perth
WA, Australia

Is it possible to see some pictures please ? :) Sounds good.

 

_________________

-charzar.

1995 EF II Fairmont
30mm lowered Lovell's springs and KYB shocks
AU XR8 snorkel

Top
 Profile  
 
 
Posted: Sat Jan 01, 2005 11:47 am 
Parts Gopher
Offline
User avatar

Posts: 64

Joined: 16th Nov 2004

Ride: 97 Falcon EL GLi

Location: Melbourne
VIC, Australia

They are not the brightest LED's, but they look much better than the stock milky yellow blubs and have the right amount of light to display the digits clearly.They are well worth 1.60 each which i payed for them and no complaints here from me. I put an LED behind the Odometer but it doesn't light it up much as the normal blub, but i still installed it there as LED life is much longer and it is still readable. i'll take a picture tonight and post it up.
Top
 Profile  
 
 
Posted: Wed Jan 05, 2005 2:55 pm 
Fordmods Newbie
Offline

Age: 34

Posts: 1

Joined: 5th Jan 2005

Ride: Fairlane

Location: Melbourne
VIC, Australia

any luck with that pic mate?
Top
 Profile  
 
 
Posted: Thu Jan 06, 2005 9:08 am 
Parts Gopher
Offline
User avatar

Posts: 64

Joined: 16th Nov 2004

Ride: 97 Falcon EL GLi

Location: Melbourne
VIC, Australia

Yeah, i did take a pic but u can't see the instrument cluster light up. Probably something wrong in my Camera. I'll try again soon
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 22 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Google [Bot] and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 11:38 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names