Fordmods Logo

Powersterring problem 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Powersterring problem
Posted: Sun Nov 07, 2004 10:20 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

Ok same car as B4 EB auto 6cyl dads
has heavy steering had abad noise from the pump
replace the pump noise went phew!

problem still there! so we flushed the oil as mush as we could has fresh fluid and the steering is marginally betta and seem to be harder to turn right than left

there is no leaks at all??? ideas?

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Sun Nov 07, 2004 10:36 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Check your rack and pipes around it.They maybe dented and have more restriction on one side to the other.AS most sytems push rather than [like some] pull...

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
Posted: Sun Nov 07, 2004 10:55 pm 
Oompa Loompa
Offline

Posts: 44

Joined: 5th Nov 2004

Location: Cheltenham
VIC, Australia

Also there is a pressure switch in the rack which may need to be reset/replaced if air got in the system. It tells the ECU to kick up the revs at idle on full lock with load on motor (air con etc) to stop it stalling. This may cause it to idle rough. Do a diagnostic.
Top
 Profile  
 
 
Posted: Sun Nov 07, 2004 11:35 pm 
Getting Side Ways
Offline

Age: 35

Posts: 1993

Joined: 5th Nov 2004

Ride: BA2 XR6T

Location: Mount Colah
NSW, Australia

also might be worth checking the tie rod ends, and intermediate shaft just in case its in that side of things.
just throwing up some other ideas !

 

_________________

BOOSTED

Top
 Profile  
 
 
Posted: Mon Nov 08, 2004 7:14 pm 
Smokin em up
Offline

Age: 31

Posts: 204

Joined: 6th Nov 2004

Gallery: 2 images

Ride: EL Futura

Location: Kurri Kurri
NSW, Australia

yep id be looking away from the power steering to the actual mehcanical steering itself. If the pump went id say its because it was doing more work than it should have been doing. SOOOOO perhaps there is a problem with a control arm or the power steering gear that is causing the power steering pump to do more work than needed. Check those areas then if you are still having probs id say a bleed of the system cos its possibly got air in it from when you replaced the pump.

Andrew
Top
 Profile  
 
 
Posted: Mon Nov 08, 2004 10:08 pm 
Parts Gopher
Offline

Age: 35

Posts: 66

Joined: 6th Nov 2004

Ride: EL XR6

Location: Adelaide
SA, Australia

check to make sure ball joints/tie rod ends arent siezed causing extra load on the pump. when i replaced the power steering pump on my xr6, i fitted a small auto transmission cooler to the return hose. just a bit of extra insurance, and had no problems since
Top
 Profile  
 
 
Posted: Tue Nov 09, 2004 1:44 am 
Smokin em up
Offline
User avatar

Age: 36

Posts: 258

Joined: 7th Nov 2004

Gallery: 6 images

Ride: '98 EL XR8

Location: Katherine
NT, Australia

I have the same problem, its heavy steering with resistance (steering wheel wont return by itself if you let go after turning a corner).

I thought it was my wheel alignment... Nope... thought it was the steering fluid.. Nope... Tyre pressure? Nope...

The only thing I have managed to figure out, if the wheel is raised to the highest position, the resistance is not there and is normal.

If I lower the wheel to the lowest position, resistance is at its highest and I have the problem.

So, Im not too sure what it could be, but it is annoying the piss outta me as well as I like to drive with the wheel low.

Anyone else have the same problem and know what it could be???

 

_________________

"...we can rebuild him, we have the technology... we just dont want to spend a lot of money."
SIX MILLION PESO FALCON

Top
 Profile  
 
 
Posted: Tue Nov 09, 2004 12:24 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

yer i not sure i had dad turn the wheel while i put my hand on the tie rods and all seemed to be fine ie i could feel no grinding etc but no idea i am able to geta rack for $150 might try that !

anyone know for sure if a EF rack fits eb?

 

_________________

RIP SCOTT

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 33 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 6:18 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names