Fordmods Logo

94 Futura 4.0L OHC, WONT REV OUT!! 

 

Page 2 of 3 [ 34 posts ] Go to page Previous  1, 2, 3  Next

 
Posted: Mon Apr 28, 2008 11:21 am 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

-SkIdZ- wrote:
SgtBourne wrote:
blocked cat mate definitely


ok ill take it off an try it lol




THERES NO CAT!!! JUST 2 MUFFLERS
Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 11:59 am 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Id be looking at the work your just did......

specifically the plugs, leads and dizzy......

If it was running right before you did the work, there is an excellent chance that your problem stems from there.....

Could be a lead tracking, or badly gapped plugs or a craked dizzy cap or stuffed coil.......

If none of that works, then you'll have to look elsewhere......

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 1:06 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

philaddis wrote:
Id be looking at the work your just did......

specifically the plugs, leads and dizzy......

If it was running right before you did the work, there is an excellent chance that your problem stems from there.....

Could be a lead tracking, or badly gapped plugs or a craked dizzy cap or stuffed coil.......

If none of that works, then you'll have to look elsewhere......


the plugs are brand new with all the right gaps leads are fine an the dizzy dosent look like anything wrong with it but its in such a f**ked up spot!!!

what i dont get is that i can hold my foot right down an start it and it will rev to 6000 an rev cut for a sec then die an do the same thing at 3500!
Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 7:28 pm 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1667

Joined: 23rd Dec 2004

Gallery: 1 images

Ride: Boosted ED XR6, EBII Mont Wgn

Power: 252 rwkw

Location: Mildura
VIC, Australia

sexyr6 wrote:
change the fuel filter if that doesnt fix it then try the fuel pump, had a similar problem with a mates car the other day, i changed the fuel pump and problem solved..

 

_________________

Image
[SEXYR-6] ED XR6 T5 Turbo Build
[EBW-347] EB Wagon V8 Stroker Build
FordMods Member #1761

Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 7:32 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

-SkIdZ- wrote:
-SkIdZ- wrote:
SgtBourne wrote:
blocked cat mate definitely


ok ill take it off an try it lol




THERES NO CAT!!! JUST 2 MUFFLERS


are you sure? the cat should be just after the exhaust manifold...

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 7:38 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

yea its just a stright pipe till it hits a muffler
Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 7:40 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

ah youre in new zealand i just realised... i read somewhere they arent law to have one in NZ?

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 7:42 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

sexyr6 wrote:
sexyr6 wrote:
change the fuel filter if that doesnt fix it then try the fuel pump, had a similar problem with a mates car the other day, i changed the fuel pump and problem solved..


theres not a fuel filter in the system if there is it must be well hitn coz i cleaned out all the fuel lines an pump still didnt fix it

(BLOODY HEAP OF s**t!!)
Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 7:44 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

alfy wrote:
ah youre in new zealand i just realised... i read somewhere they arent law to have one in NZ?


lol!! i dont think i have had a car with one in it aye.
all i knw is that u can get a bit of money for them for scrap
Top
 Profile  
 
 
Posted: Mon Apr 28, 2008 9:27 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 4326

Joined: 30th Oct 2006

Gallery: 18 images

Ride: Envi EF

Location: Grafton
NSW, Australia

It definetely has a fuel filter dude. its hidden behind the chassis rail on the passenger side.

 

_________________

>>>EF Futura T build<<<

Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 9:22 am 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

i pulled the dizy cap off and all the thingys were dirty so i cleaned them now it runs ruff and sounds like a old bomb!
Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 9:37 am 
Getting Side Ways
Offline
User avatar

Posts: 1008

Joined: 21st Dec 2004

Ride: ED V8

Location: driving under the sun........now!
WA, Australia

Have a look at your leads then mate.....

You would've disrupted them when cleaning the dizzy. Quite possibly one or some of them are tracking all the time and leading it to run like a pig.

that'd be my next step.

Also, could be the TFI module on the dizzy. But when they die, I think they just fail. They don't play up like that.

 

_________________

ED XR8 Spri-mitatio-nt

Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 10:45 am 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

ive been over and over the leads the plugs the fuel.. theres no fuel filter at all i followed the lines back form the tank and cleaned them all out!.

i dont have any idea what it could be im just about ready 2 push it in the dump an burn it! lol.

i think its a bit more than plugs dizzy or wires. it mite be the computer telling it to hit rev cut at 3500???

some1 out there must have run into this problem b4?
Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 12:04 pm 
Fordmods Newbie
Offline

Posts: 17

Joined: 27th Apr 2008

Location: hamilton
New Zealand

ok i must of done sumthing cause its reving out now! lol

dose any1 no a website were i can order a new dizzy cap and leads?
Top
 Profile  
 
 
Posted: Tue Apr 29, 2008 2:31 pm 
Getting Side Ways
Offline

Age: 27

Posts: 1323

Joined: 12th Nov 2006

Gallery: 9 images

Ride: 02 xls ute 347

Location: adelaide
SA, Australia

what did you do for it to rev out again
if it does it a again borrow on of your mates or some ones ecu with the same car as you and if it dont do it any more with the otehr ecu then u no u have ecu probs

 

_________________

02 series 3 AU marline ute 5speed 347 stroker

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 3  [ 34 posts ]  Go to page Previous  1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 9:37 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names