Fordmods Logo

parkers, number plate light and hazards not working 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: parkers, number plate light and hazards not working
Posted: Thu May 15, 2008 9:54 pm 
Smokin em up
Offline
User avatar

Age: 27

Posts: 238

Joined: 31st Jan 2008

Gallery: 3 images

Ride: EF

Location: ballarat
VIC, Australia

the other day i noticed my parkers were't working so i had a better look and the interior instrument cluster isnt lighting up either along with the hazards not working as it keeps blowing a fuse
i probably need to go to an auto elec but if i can save money with somethin simple it would help

any ideas would be appreciated

 

_________________

If it has wheels or a skirt, You can't afford it.

Top
 Profile  
 
 
Posted: Fri May 23, 2008 11:52 pm 
Fordmods Newbie
Offline

Age: 44

Posts: 14

Joined: 23rd May 2008

Location: emerald
QLD, Australia

you have a short to ground easy way is to disconnect one circuit at a time and keep trying a fues until it stops blowing then find cause in that circuit more than likley is bare wire touching metal
Top
 Profile  
 
 
 Post subject: Re: parkers, number plate light and hazards not working
Posted: Wed Jun 13, 2012 6:42 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 2

Joined: 16th Apr 2012

Ride: 1996 EF Falcon (ex Chaser)

Location: brisbane
QLD, Australia

wild_cleveland wrote:
the other day i noticed my parkers were't working so i had a better look and the interior instrument cluster isnt lighting up either along with the hazards not working as it keeps blowing a fuse
i probably need to go to an auto elec but if i can save money with somethin simple it would help

any ideas would be appreciated


I had the same problem in my ef, turns out the right parker wires were grounding together and blowing the fuse. The reason why the parkers, tail lights and hazard lights and instrument lights cut out is because they are all connected. Check your tail light bulbs, parker bulbs and indicator bulbs. If any are blown this could cause it. If none are blown, something is earthing somewhere it shouldnt be.

Mine was an easy fix. This thread helped me: ford-interior-f14/park-lamp-fuse-keeps-blowing-t87166.html
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Oct 22, 2017 3:46 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names